poj1611 解题报告

并查集学习过之后做了几道相关联系,这里贴出1611
The Suspects
Time Limit: 1000MS   Memory Limit: 20000K
Total Submissions: 20494   Accepted: 9940

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1


题中要计算感染患者的人数,因此想到要把感染患者放到同一个集合中,即出现一个与0号患者同组的同学,则把这个同学放入到与0相同的集合中,把与0不是同组的同学放到另一个集合中,因此想到用并查集解这道题。0节点不一定是这个集合的根节点,所以最后要找到0节点的根节点,然后计算根节点所包含的子节点的数目。
代码:
#include <iostream>
using namespace std;

int father[30000], num[30000];

void Make_set(int x)
{
    father[x] = x;
        //没有用到秩,而是设置每个集合中所包含节点的数目
    num[x] = 1;
}

int Find_set(int x)
{
    if(x != father[x])
        father[x] = Find_set(father[x]);
    return father[x];
}

void Union(int x, int y)
{
    int GrandX = Find_set(x);
    int GrandY = Find_set(y);

    if(GrandX == GrandY)
        return;
    if(num[GrandX] < num[GrandY])
    {
        father[GrandX] = GrandY;
        num[GrandY] += num[GrandX];
    }else 
    {
        father[GrandY] = GrandX;
        num[GrandX] += num[GrandY];
    }
}

int main()
{
    int n, m;
    while(cin >> n, cin >> m)     //cin >> n, cin >> m
    {
        if((m==0) && (n==0))
            break;

        //为每个节点创建一个新的集合
        for(int i = 0; i < n; i++)
            Make_set(i);

        for(int i = 0; i < m; i++)
        {
            int count, first;
            cin >> count;
            cin >> first;
            for (int j = 1; j < count; j++)
            {
                int temp;
                cin>> temp;
                Union(temp, first);
            }
        }
        
        cout << num[Find_set(0)] << endl;
    }
    return 0;
}

    

 

posted on 2014-04-11 10:46  horizon.qiang  阅读(395)  评论(0编辑  收藏  举报

导航