VS2019 MSB364 未找到框架“NETFramework,Version=v4.7”

环境:

WIN 10

VS2019 已安装框架v4.7.2

问题:

在打开一些早期项目时,编译报 MSB364 错误,未找到框架“NETFramework,Version=v4.7”或未找到框架“NETFramework,Version=v4.7.1”

 

解决过程:

1、尝试安装NETFramework 4.7失败;报:这台计算机中已经安装了 .NET Framework 4.7 或版本更高的更新。

2、尝试安装.NET Framework 4.7  Developer Pagckage无效,虽然在程序和功能中看到.NET Framework 4.7 SDK,及目标包,VS2019任然无法发现.NET Framework 4.7

 

3、打开Visual studio Installer安装程序,点击“修改”按钮,在菜单栏,找到单个组件菜单,选择需要安装的版本,即可修复问题

 

posted @ 2019-05-27 21:35  hobinly  阅读(1866)  评论(0编辑  收藏