POJ1087:A Plug for UNIX(最大流)

A Plug for UNIX

题目链接:https://vjudge.net/problem/POJ-1087

Description:

You are in charge of setting up the press room for the inaugural meeting of the United Nations Internet eXecutive (UNIX), which has an international mandate to make the free flow of information and ideas on the Internet as cumbersome and bureaucratic as possible. 
Since the room was designed to accommodate reporters and journalists from around the world, it is equipped with electrical receptacles to suit the different shapes of plugs and voltages used by appliances in all of the countries that existed when the room was built. Unfortunately, the room was built many years ago when reporters used very few electric and electronic devices and is equipped with only one receptacle of each type. These days, like everyone else, reporters require many such devices to do their jobs: laptops, cell phones, tape recorders, pagers, coffee pots, microwave ovens, blow dryers, curling 
irons, tooth brushes, etc. Naturally, many of these devices can operate on batteries, but since the meeting is likely to be long and tedious, you want to be able to plug in as many as you can. 
Before the meeting begins, you gather up all the devices that the reporters would like to use, and attempt to set them up. You notice that some of the devices use plugs for which there is no receptacle. You wonder if these devices are from countries that didn't exist when the room was built. For some receptacles, there are several devices that use the corresponding plug. For other receptacles, there are no devices that use the corresponding plug. 
In order to try to solve the problem you visit a nearby parts supply store. The store sells adapters that allow one type of plug to be used in a different type of outlet. Moreover, adapters are allowed to be plugged into other adapters. The store does not have adapters for all possible combinations of plugs and receptacles, but there is essentially an unlimited supply of the ones they do have.

Input:

The input will consist of one case. The first line contains a single positive integer n (1 <= n <= 100) indicating the number of receptacles in the room. The next n lines list the receptacle types found in the room. Each receptacle type consists of a string of at most 24 alphanumeric characters. The next line contains a single positive integer m (1 <= m <= 100) indicating the number of devices you would like to plug in. Each of the next m lines lists the name of a device followed by the type of plug it uses (which is identical to the type of receptacle it requires). A device name is a string of at most 24 alphanumeric 
characters. No two devices will have exactly the same name. The plug type is separated from the device name by a space. The next line contains a single positive integer k (1 <= k <= 100) indicating the number of different varieties of adapters that are available. Each of the next k lines describes a variety of adapter, giving the type of receptacle provided by the adapter, followed by a space, followed by the type of plug.

Output:

A line containing a single non-negative integer indicating the smallest number of devices that cannot be plugged in.

Sample Input:

4 
A 
B 
C 
D 
5 
laptop B 
phone C 
pager B 
clock B 
comb X 
3 
B X 
X A 
X D 

Sample Output:

1

题意:

这个题意挺难理解的,一开始输入的是插座,然后输入的是插头,最后输入的是转换器。

转换器后面有两个字符串,也就是说能够把插头为第一个的转化为第二个字符串,这里插头有无限个。

要求最大能让多少插头连上插座。

 

题解:

首先考虑建图的两边,源点连每个插头且边权为1,然后每个插座连上汇点且边权为1。

然后每个插座可以使X->Y(举例),我们就可以想让X连一条边权为无穷大的边到Y。

最后跑一个最大流就是了。注意下输入时对字符串的处理。

注意数组要开到500左右,因为点的最多可能是400。

我这里建图是反过来建的,为了方便~

 

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <vector>
#include <queue>
#include <map>
#define INF 99999999
#define t 500
using namespace std;

const int N = 505;
int head[N],d[N];
int tot,n,m,k,cnt;
struct Edge{
    int v,next,c;
}e[N<<1];
char str[N][30],s[30],tmp[30];
void adde(int u,int v,int c){
    e[tot].v=v;e[tot].next=head[u];e[tot].c=c;head[u]=tot++;
    e[tot].v=u;e[tot].next=head[v];e[tot].c=0;head[v]=tot++;
}
bool bfs(int S,int T){
    memset(d,0,sizeof(d));d[S]=1;
    queue <int > q;q.push(S);
    while(!q.empty()){
        int u=q.front();q.pop();
        for(int i=head[u];i!=-1;i=e[i].next){
            int v=e[i].v;
            if(!d[v] && e[i].c>0){
                d[v]=d[u]+1;
                q.push(v);
            }
        }
    }
    return d[T]!=0;
}
int dfs(int s,int a){
    int flow=0,f;
    if(s==t || a==0) return a;
    for(int i=head[s];i!=-1;i=e[i].next){
        int v=e[i].v;
        if(d[v]!=d[s]+1) continue ;
        f=dfs(v,min(a,e[i].c));
        if(f){
            e[i].c-=f;
            e[i^1].c+=f;
            flow+=f;
            a-=f;
            if(a==0) break;
        }
    }
    if(!flow) d[s]=-1;
    return flow;
}
int Dinic(){
    int max_flow = 0;
    while(bfs(0,t)){
        max_flow+=dfs(0,INF);
    }
    return max_flow;
}
int num=0;
int Search(char *s){
    if(num==0){
        strcpy(str[1],s);
        num++;
        return 1;
    }
    for(int i=1;i<=num;i++){
        if(strcmp(str[i],s)==0) return i;
    }
    num++;
    strcpy(str[num],s);
    return num;
}
int main(){
    scanf("%d",&n);
    memset(head,-1,sizeof(head));
    for(int i=1;i<=n;i++){
        scanf("%s",s);
        int a=Search(s);
        adde(0,a,1);
    }
    scanf("%d",&m);
    for(int i=1;i<=m;i++){
        scanf("%s%s",tmp,s);
        int a=Search(s);
        adde(a,t,1);
    }
    scanf("%d",&k);
    for(int i=1;i<=k;i++){
        scanf("%s%s",tmp,s);
        int a=Search(tmp),b=Search(s);
        adde(b,a,INF);
    }
    printf("%d",m-Dinic());
    return 0;
}

 

posted @ 2018-12-07 22:08  heyuhhh  阅读(226)  评论(0编辑  收藏  举报