poj2184 Cow Exhibition

Description

"Fat and docile, big and dumb, they look so stupid, they aren't much
fun..."
- Cows with Guns by Dana Lyons

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.

Input

* Line 1: A single integer N, the number of cows

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS:

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value
of TS+TF to 10, but the new value of TF would be negative, so it is not
allowed.
这题属于01背包,花了很长时间才看懂。。。这题的关键是把s转换为质量,f转换为价值,用dp[i]表示i这个质量下的最大价值,因为s[i]可能为负数,所以先预处理把所有的s[i]都加上100000,然后dp[100000]=0,其余dp[]=-inf.最后计算的时候从100000开始计算,如果dp[i]>=0,那么表示此时的f[i]>=0,之前的ans和dp[i]+i-100000相比较。注意,如果循环到某个i,s[i]<0,那么用背包的时候是从小到大的,其实这和一维背包的原理有关,如果是二维的话,那么都可以用从小到大的方式循环,因为前面计算的值和后面的没有影响,但用一维写,前面可能会影响后面的,所以要避免这样的影响,所以才有顺序。
#include<stdio.h>
#include<string.h>
#define maxn 100000
#define inf 88888888
int w[1005],v[1005],dp[2*maxn+10];
int max(int a,int b){
	return a>b?a:b;
}
int main()
{
	int n,m,i,j,ans;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=1;i<=n;i++){
			scanf("%d%d",&w[i],&v[i]);
		}
		for(i=0;i<=2*maxn;i++){
			dp[i]=-inf;
		}
		dp[maxn]=0;
		for(i=1;i<=n;i++){
			if(w[i]<0 && v[i]<0)continue;
			if(w[i]>0){
				for(j=2*maxn;j>=w[i];j--){
					if(dp[j-w[i]]>-inf)
					dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
				}
			}
			else{
				for(j=0;j<=2*maxn+w[i];j++){
					if(dp[j-w[i]]>-inf)
					dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
				}
			}
		}
		ans=-inf;
		for(i=maxn;i<=2*maxn;i++){
			if(dp[i]>=0){
				ans=max(ans,dp[i]+i-maxn);
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}


posted @ 2015-06-20 14:58  Herumw  阅读(122)  评论(0编辑  收藏  举报