Windows XP 的最高版本 .net framework 安装

注意:

Windows XP 系统已于2014年4月8日停止维护。出于安全、性能及新设备支持考虑,应立即停止使用。

安装

Windows XP SP3 所支持的最高.net framework 版本为 4.0.3。

安装过程为:

  1. 检查XP系统版本,选择 X86 或 X64 版本的安装包
  2. 安装.net framework 4.0
  3. 安装 KB2600211 更新,此更新为 .net framework 4.0.3 更新
  4. 如果需要开发环境支持,安装 .net framework 4.0.3 multitaget pack

对于需要在Windows XP上进行开发的情况,可安装 VisualStudio 2010,这是支持XP的最后的VS版本。

开发者

在Win7 或之后的系统中开发目标为 .net framework 4.0.3 的桌面程序时,需要注意 使用 VS2015 及之前的开发环境,否则可能导致不明的兼容性问题。

将新项目向低版本C#移植时,需要注意取消部分语法,以兼容老版本的C#标准。

posted @ 2019-01-14 12:41 崩溃侠 阅读(...) 评论(...) 编辑 收藏
友情链接: Heroius' Ideas 沈阳因斯福环保安全科技有限公司 东北大学工业爆炸防护研究所