poj-1200-hash-

Crazy Search
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 27602   Accepted: 7711

Description

Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle. 
Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text. 

As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa"; "aab"; "aba"; "bab"; "bac". Therefore, the answer should be 5. 

Input

The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.

Output

The program should output just an integer corresponding to the number of different substrings of size N found in the given text.

Sample Input

3 4
daababac

Sample Output

5

Hint

Huge input,scanf is recommended.

Source

 
题目大意,输入一个子串长度和一个字符种数,然后判断该字符串中的连续子串的个数,重复的不参与重复计算。
题目思路,对每个子串进行hash就可以了。
 
#include<cstdio>
#include<cstring>

#define N 16000003
bool hash[N]; //保存子串是否出现过
char w[N];   //保存字符串
int id[500]; //保存字符串中每个字符的值

int main()
{
    int n,nc,i,j;
    while(~scanf("%d%d",&n,&nc))
    {

        memset(hash,false,sizeof(hash));   //hash数组初始化
        memset(id,-1,sizeof(id));
        int cnt=0;             //cnt值用来作为每个字符的哈希值
        scanf("%s",w);
        int len=strlen(w);
        for(i=0;i<len&&cnt<nc;i++)
        {

            if(id[w[i]]!=-1) continue;
            id[w[i]]=cnt++;
        }
        int ans=0;
        for(i=0;i<len-n+1;i++)
        {

            int s=0;
            for(j=i;j<i+n;j++)
            {
                s=s*nc+id[w[j]];    //每个子串的cn进制数字
            }
            if(hash[s]) continue;
            ans++;
            hash[s]=true;
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

 

posted @ 2016-09-18 14:04  TomJarry  阅读(301)  评论(0编辑  收藏  举报