hdoj - 2602 Bone Collector

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
 

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 
Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 
Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 
Sample Output
14
 
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;
int a[1005],b[1005],dp[1005];
int main()
{
    int t,n,v;
    scanf("%d",&t);
    for(int k=0;k<t;k++)
    {
        memset(dp,0,sizeof(dp));
        scanf("%d %d",&n,&v);
        for(int i = 0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        for(int i = 0;i<n;i++)
        {
            scanf("%d",&b[i]);
        }

        for(int i = 0;i<n;i++)
        {
            for(int j = v;j>=b[i];j--)
            {
                dp[j] = max(dp[j],dp[j-b[i]]+a[i]);      //关键代码

            }
        }
        printf("%d\n",dp[v]);
    }
    return 0;
}

 

posted @ 2019-05-06 16:37  彩虹色  阅读(102)  评论(0编辑  收藏  举报