会员
周边
新闻
博问
闪存
赞助商
Chat2DB
所有博客
当前博客
我的博客
我的园子
账号设置
会员中心
简洁模式
...
退出登录
注册
登录
Harda
博客园
首页
新随笔
联系
订阅
管理
上一页
1
···
5
6
7
8
9
10
11
12
13
下一页
2022年12月21日
MySQL Threads Running
摘要: 1、 广电告警背景如下: 主机:xxxx:3306,MySQL 运行的Thread大于30,请关注,2021-07-15 15:30:002、猜测是因为业务量造成?3、mysql thread running 的理解 每秒查询次数(Queries per second,QPS)可以衡量数据库的吞吐量
阅读全文
posted @ 2022-12-21 09:07 Harda
阅读(1089)
评论(0)
推荐(1)
2022年12月20日
MySQL-SQL审计工具SOAR
摘要: OAR (SQL Optimizer And Rewriter) 是一个对 SQL 进行优化和改写的自动化工具。 由小米人工智能与云平台的数据库团队开发与维护 一、简介 1、功能特点 跨平台支持(支持 Linux, Mac 环境,Windows 环境理论上也支持,不过未全面测试) 目前只支持 MyS
阅读全文
posted @ 2022-12-20 18:08 Harda
阅读(1771)
评论(0)
推荐(0)
缓存穿透 - Redis Module 之布隆过滤器
摘要: 一、场景案例 假设目前有一后端接口GET /userinfo/100,实际数据库内也只有最大ID为100的用户。 对于请求参数100以内当然属于是合法请求,但对于10000这种来说明显就异常的请求一样会进入数据库中进行查询,白白消耗DB资源,这就是——缓存穿透。 二、缓存知识 为了方便阅读此处直接上
阅读全文
posted @ 2022-12-20 14:18 Harda
阅读(129)
评论(0)
推荐(0)
故障分析 | MySQL死锁案例分析
摘要: 一 背景 死锁,其实是一个很有意思也很有挑战的技术问题,大概每个DBA和部分开发同学都会在工作过程中遇见过。本次分享的死锁案例更新不存在的记录加上 X GAP lock 和 insert 的意向锁冲突。希望能够对想了解死锁的朋友有所帮助。 二 案例分析 2.1 业务逻辑 业务逻辑: 业务需要并发不同
阅读全文
posted @ 2022-12-20 11:51 Harda
阅读(136)
评论(0)
推荐(0)
MySQL锁等待超时一例分析
摘要: 1、问题现象 开发反馈某业务持续性报锁等待超时,相关错误信息如下: Lock wait timeout exceeded; try restarting transaction 为了能精确定位问题,继续询问开发有没有锁等待超时相关SQL,开发又给了相关报错SQL: INSERT INTO <TABL
阅读全文
posted @ 2022-12-20 11:22 Harda
阅读(215)
评论(0)
推荐(0)
MySQL批量插入数据的四种方案(性能测试对比)
摘要: 本文记录个人使用MySQL插入大数据总结较实用的方案,通过对常用插入大数据的4种方式进行测试,即for循环单条、拼接SQL、批量插入saveBatch()、循环 + 开启批处理模式,得出比较实用的方案心得。 一、前言 最近趁空闲之余,在对MySQL数据库进行插入数据测试,对于如何快速插入数据的操作无
阅读全文
posted @ 2022-12-20 10:44 Harda
阅读(946)
评论(0)
推荐(0)
2022年12月16日
MySQL kill进程后出现killed
摘要: 一.问题描述 拷贝一个大表的表数据的时候,等待时间太久,就在前台通过CTRL+C的方式停掉了 通过show processlist查找到对应的进程,然后进行kill,结果kill完了,依旧在进程列表里,只是被标记为killed 二.解决方案 查看innodb的事务表,发现刚才kill的语句正在进行回
阅读全文
posted @ 2022-12-16 09:26 Harda
阅读(864)
评论(1)
推荐(0)
2022年12月13日
zookeeper数据迁移及恢复
摘要: 在应用系统上云迁移的时候经常会遇到中间件的数据迁移,今天就和大家介绍一下zookeeper的数据如何迁移与恢复。 第一步:从原系统环境zookeeper服务器的数据目录下复制最新的日志和快照文件。 先去zookeeper的配置文件中找到data目录存放路径: cd /usr/local/zookee
阅读全文
posted @ 2022-12-13 17:53 Harda
阅读(2168)
评论(0)
推荐(1)
2022年12月1日
1+N环境-分布式数据库mysql8系列故障重启问题处理
摘要: 1、背景 多个业务连接异常,navicat连接数据库不稳定,连接进入数据库后也会出现卡死的,连接失败的报错 2、问题分析 2.1 问题描述: navicat、服务器中连接数据库均复现业务报告的问题,查看后端mysql库日志,mysql主库在连续地故障重启。数据库使用的是主备模式,mysql切换到备库
阅读全文
posted @ 2022-12-01 09:22 Harda
阅读(310)
评论(0)
推荐(0)
1+N环境MySQL8.0.29/30版本BUG处理措施
摘要: 背景:前期安全漏扫后,1+N环境中部分MySQL8.0数据库由低版本通过upgrade方式升级到8.0.29版本,后又升级到8.0.30版本。此版本的upgrade升级方式,在执行 alter table add colmun 操作时有一定几率会触发MySQL内部BUG,导致数据库崩溃。注意:MyS
阅读全文
posted @ 2022-12-01 09:08 Harda
阅读(858)
评论(0)
推荐(0)
上一页
1
···
5
6
7
8
9
10
11
12
13
下一页
公告