冠军

导航

升级到 .NET Core 3.1

微软升级的频率有点快,转眼 .NET Core 升级到 3.1 版了,这是一个长期支持版本,意味着 .NET Core 正式进入成熟期。

不过,对于开发人员来说,你的项目又需要迁移了。

升级项目文件

对于 ASP.NET Core 3.1 ,你需要 TargetFramework 设置为 netcoreapp3.1, 并且,在 .NET Core 2.0 中,需要引用的 Microsoft.AspNetCore.All 也不再需要。或者在 .NET Core 2.2 中的 Microsoft.AspNetCore.App 也一样不再需要, 你的基础项目文件看起来如下所示:

<Project Sdk="Microsoft.NET.Sdk.Web">

  <PropertyGroup>
    <TargetFramework>netcoreapp3.1</TargetFramework>
  </PropertyGroup>

</Project>

是不是非常清爽?

框架引用

通过上述某个包提供的 ASP.NET Core 功能,也作为 Microsoft.AspNetCore.App 共享框架的一部分提供。 共享框架是安装在计算机上并包括运行时组件和目标包的一组程序集( .dll 文件)。 有关详细信息,请参阅共享框架

  • 面向 Microsoft.NET.Sdk.Web SDK 的项目,已经隐式引用了 Microsoft.AspNetCore.App 框架。对于这些项目,不需要其他引用:
  • <Project Sdk="Microsoft.NET.Sdk.Web">
      <PropertyGroup>
        <TargetFramework>netcoreapp3.0</TargetFramework>
      </PropertyGroup>
        ...
    </Project>

     

  • 面向 Microsoft.NET.SdkMicrosoft.NET.Sdk.Razor SDK 的项目,注意这两个里面没有 Web 这个词,应该显式在 FrameworkReference 中应用 Microsoft.AspNetCore.App:
  • <Project Sdk="Microsoft.NET.Sdk.Razor">
      <PropertyGroup>
        <TargetFramework>netcoreapp3.0</TargetFramework>
      </PropertyGroup>
    
      <ItemGroup>
        <FrameworkReference Include="Microsoft.AspNetCore.App" />
      </ItemGroup>
        ...
    </Project>

     

 

https://natemcmaster.com/blog/2018/08/29/netcore-primitives-2/

 

 

 

posted on 2020-03-28 17:47  冠军  阅读(1983)  评论(0编辑  收藏