摘要: 代码没问题的前提下,考虑可能是这种原因: 你可能在代码中使用了val()方法付来更新输入框的值,请注意,使用val()方法更新输入框的值不会触发change事件 ; 但是可以使用以下这种方法手动触发change事件 ; $('#input').val('新的值').trigger('change') 阅读全文
posted @ 2023-10-24 12:29 戈丫汝 阅读(173) 评论(0) 推荐(0) 编辑
摘要: 我的需求是从公众号h5页面,点击跳转某个a链接跳转到小程序,此文档也是记录我的实现过程. 开发语音:PHP 前期准备工作: 微信公众号ip白名单设置 js授权安全域名设置 access_token获取权限设置 设置此次开发相关的工作: 登录微信公众后台(公众号账号);绑定跳转目标小程序; PHP获取 阅读全文
posted @ 2023-10-17 19:13 戈丫汝 阅读(178) 评论(0) 推荐(0) 编辑
摘要: 关于 8 月 10 日微信官方发布公告 关于小程序隐私保护指引设置的公告,从 2023 年 9 月 15 日起必须用户点击同意隐私保护政策并同步给微信之后,开发者才可以调用微信提供的隐私接口。 了解 首先,涉及到使用了隐私接口的小程序必须在「小程序管理后台」设置《小程序用户隐私保护指引》,微信一共提 阅读全文
posted @ 2023-09-10 13:16 戈丫汝 阅读(963) 评论(0) 推荐(0) 编辑
摘要: 优点 操作 方便,布局简单 移动端应用广泛 PC端浏览器支持情况较差 低版本浏览器不支持 布局原理 flexible box的缩写 “弹性布局”,用来为盒状模型提供最大的灵活性,任何一个容器都可以指定为flex布局 采用flex布局的元素称为flex container,所有子元素自动成为容器成员, 阅读全文
posted @ 2023-05-17 13:04 戈丫汝 阅读(13) 评论(0) 推荐(0) 编辑
摘要: 最近写小程序遇到的,在百度地图坐标拾取获取的经纬度,在map插件上实际定位出的位置有不小的偏差,查了资料知道了问题所在,分享出来: 因为百度地图的地理坐标是 bd=09 标准, 世界地图是 wgs-84标准 , 国测局是gcj-02标准 . 微信默认使用的国测局坐标,所以找 gcj-02标准的坐标获 阅读全文
posted @ 2022-12-02 17:59 戈丫汝 阅读(1199) 评论(0) 推荐(1) 编辑
摘要: 显示如下: 就用快捷生成curd的内容,控制器什么的不需要做任何变动,保证你的数据库字段长度够即可. 新增页面: <div class="form-group"> <label class="control-label col-xs-12 col-sm-2">{:__('Advantage_en') 阅读全文
posted @ 2022-01-05 15:54 戈丫汝 阅读(232) 评论(0) 推荐(0) 编辑
摘要: //生成fa_test表的CRUD且一键生成菜单php think crud -t test -u 1//删除fa_test表生成的CRUDphp think crud -t test -d 1//生成fa_test表的CRUD且生成关联模型category,外链为category_id,关联表主键 阅读全文
posted @ 2021-12-27 17:53 戈丫汝 阅读(950) 评论(0) 推荐(0) 编辑
摘要: 微信开发者工具能调试小程序,手机端加载不出来,单独拿出来接口访问正常.解决办法: 1.先去 https://www.myssl.cn/tools/check-server-cert.html 检测自己域名的证书是否存在问题 我的是证书2缺失 2. 把缺的证书放到服务器并在这个配置文件引入即可,证书检 阅读全文
posted @ 2021-12-22 15:58 戈丫汝 阅读(1048) 评论(0) 推荐(0) 编辑
摘要: 第一种的方法: 需要在引入的img样式上写入: object-fit: cover; object-position: top;//可能有时候图片不是从头部开始截图的 所以需要定位一下 第二种的方法就是引入背景图 样式中写入 width: 125px; height: 125px; backgrou 阅读全文
posted @ 2021-12-22 15:15 戈丫汝 阅读(870) 评论(0) 推荐(0) 编辑
摘要: 1.后台插件管理付费安装插件后,点击配置,配置端口等信息: 2.阿里云配置安全组: 放行 1818 2828 1238 3.php.ini里边搜索disable_functions然后把它后面,所有以pcntl开头的函数都取消禁用,重新启动,再开启(获取找到网站对应php版本,去删除pcntl的禁用 阅读全文
posted @ 2021-12-13 18:21 戈丫汝 阅读(785) 评论(0) 推荐(0) 编辑