dbvis MySQL server version for the right syntax to use near 'OPTION SQL_SELECT_LIMIT=DEFAULT' at line 1

转自:http://www.cnblogs.com/_popc/p/4053593.html

今天使用数据库查询工具DBvis链接mysql数据库时, 发现执行如何sql语句, 都报如下错误:

后来想着应该是mysql驱动包的版本不对导致的, 如何你和我一样, 也是这个问题困扰,那么现在就知道怎么回事了。 

我的版本如下:

解决办法:

去mysql官网下载最新的jar驱动包 然后更新就行.

url:http://dev.mysql.com/downloads/connector/j/

选择平台,下载(mysql-connector-java-5.1.33.tar.gz)

最后更新到dbvis jar包到相应的目录下就行,删除原来的,重启dbvis启动时,会自动检测并加载使用:

jar包目录如下:D:\Program Files\dbvis\dbvis_windows_8_0_9\DbVisualizer-8.0.9\jdbc\mysql

tools-->driver manager--->左侧找到mysql驱动的目录, 更新就行

如下附带mysql 最新驱动jar包地址:

http://pan.baidu.com/s/1m2NE2

posted @ 2017-10-11 21:15  追梦的独行者  阅读(1896)  评论(1编辑  收藏  举报