1053. Path of Equal Weight (30)

Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to Lis defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.


Figure 1

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A1, A2, ..., An} is said to be greater than sequence {B1, B2, ..., Bm} if there exists 1 <= k < min{n, m} such that Ai = Bifor i=1, ... k, and Ak+1 > Bk+1.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2


#include<iostream>
#include<vector>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
using namespace std;
#define max 102
vector<int>vt[max];
vector<int>result[max];
vector<int>weight;
int sweight;
int t=0;
vector<int>curpath;
void dfs(int s,int len){
	if(vt[s].empty())return;
	int tmplen = len;
	int size=vt[s].size();
	for(int i=0;i<size;i++){
		tmplen=len + weight[vt[s][i]];
		if(tmplen<sweight){
			vector<int>tmp;
			tmp=curpath;
			curpath.push_back(weight[vt[s][i]]);
			dfs(vt[s][i],tmplen);
			curpath=tmp;
		}else if(tmplen==sweight && vt[vt[s][i]].empty()){
			result[t]=curpath;
			result[t].push_back(weight[vt[s][i]]);
			t++;
		}
	}
}
bool cmp(vector<int>a,vector<int>b){
	int sizea=a.size();
	int sizeb=b.size();
	int minSize=sizea<sizeb?sizea:sizeb;
	for(int i=0;i<minSize;i++){
		if(a[i]>b[i])return true;
		else if(a[i]<b[i]) return false;
	}
	if(sizea==minSize){
		return false;
	}else {
		return true;
	}
}
int main(){
	int n,m;
	scanf("%d%d%d",&n,&m,&sweight);
	int i,j;
	int val,id,k;
	weight.resize(n);
	for(i=0;i<n;i++){
		scanf("%d",&weight[i]);
	}
	for(i=0;i<m;i++){
		scanf("%d%d",&id,&k);
		for(j=0;j<k;j++){
			scanf("%d",&val);
			vt[id].push_back(val);
		}
	}
	if(m==0){
		if(weight[0]==sweight)printf("%d\n",weight[0]);
		return 0;
	}
	curpath.push_back(weight[0]);
	dfs(0,weight[0]);
	sort(result,result+t,cmp);
	for(i=0;i<t;i++){
		int size=result[i].size();
		printf("%d",result[i][0]);
		for(j=1;j<size;j++){
			printf(" %d",result[i][j]);
		}
		printf("\n");
	}
	return 0;
} 

  

posted @ 2017-11-21 18:50  gaoren  阅读(239)  评论(0编辑  收藏  举报