1057. Stack (30)

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian -- return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<= 105). Then N lines follow, each contains a command in one of the following 3 formats:

Push key
Pop
PeekMedian

where key is a positive integer no more than 105.

Output Specification:

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print "Invalid" instead.

Sample Input:

17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop

Sample Output:

Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid

解题思路:multiset,STL的库还是很好用的,之前还不知这些,还需要一个个慢慢学习才行,map,set,vector,stack,queue。至少常用的要能够熟悉使用。利用s1来保存小于mid的数,s2来保存大于mid的数,且s1.size()要等于s2.size()或者s1.size()+1要等于s1.size(),这样就可以保证s1的最后一个点就是mid。(这题堆的特性也可以解决。)


#include<iostream>
#include<cstdio>
#include<set>
#include<stack>
#include<vector>
#include<algorithm>
#include<cstring>
using namespace std;
multiset<int>s1,s2;//s1<mid,s2>mid;
int mid;
void update(){
	multiset<int>::iterator it;
	if(s1.size() < s2.size()){
		it = s2.begin();
		s1.insert(*it);
		s2.erase(it);
	}
	if(s1.size() > s2.size() + 1){
		it = s1.end();
		it--;
		s2.insert(*it);
		s1.erase(it);
	}
	if(!s1.empty()){
		it = s1.end();
		it --;
		mid = *it;
	}
}
int main(){
	int n;
	scanf("%d",&n);
	stack<int>st;
	while(n--){
		char str[12];
		int tmp;
		scanf("%s",str);
		if(strcmp(str,"Pop")==0){
			if(st.empty()){
				printf("Invalid\n");
			}else{
				tmp=st.top();
				st.pop();
				printf("%d\n",tmp);
				if(tmp<=mid){
					s1.erase(s1.find(tmp));
				}else{
					s2.erase(s2.find(tmp));
				}
				update();
			}
		}else if(strcmp(str,"Push")==0){
			int val;
			scanf("%d",&val);
			st.push(val);
			if(val<=mid){
				s1.insert(val);
			}else {
				s2.insert(val);
			}
			update();
		}else if(strcmp(str,"PeekMedian")==0){
			if(st.empty()){
				printf("Invalid\n");
			}else {
				printf("%d\n",mid);
			}
		}
	}
	return 0;
}
 

  





posted @ 2017-11-17 16:15  gaoren  阅读(174)  评论(0编辑  收藏  举报