1069. The Black Hole of Numbers (20)

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the "black hole" of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0, 10000).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation "N - N = 0000". Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;
int a[5],val;
bool cmp(int a,int b){
	return a>b;
}
int main(){
	scanf("%d",&val);
	int tmp = val;
	while(1){
		a[0]=val/1000;
		val=val-a[0]*1000;
		a[1]=val/100;
		val=val-a[1]*100;
		a[2]=val/10;
		a[3]=val-a[2]*10;
		if(a[0]==a[1]&&a[1]==a[2]&&a[2]==a[3]){
			printf("%04d - %04d = 0000\n",tmp,tmp);
			return 0;
		}
		sort(a,a+4,cmp);
		int val1=0;
		int val2=0;
		for(int i=3;i>=0;i--){
			val1=val1*10+a[i];
			val2=val2*10+a[3-i];
		}
		val=val2-val1;
		printf("%04d - %04d = %04d\n",val2,val1,val);
		if(val==6174){
			break;
		}
	}
	return 0;
} 

  



posted @ 2017-11-16 21:40  gaoren  阅读(223)  评论(0编辑  收藏  举报