1031. Hello World for U (20)

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

 

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

题目大意:把字符串的输出按U形样式输出。
解题思路:可根据公式n1=n3=max{k|k<=n2 for all 3<=n2<=N}和n1+n2+n3-2=N,对n1与n2进行遍历,先求解出n1和n2的值。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main(){
	char s1[81],s2[81][81];
	scanf("%s",s1);
	int length=strlen(s1);
	int i,j;
	int n = length+2;
	int flag=0;
	for(i=1;i<=length;i++){
		for(j=1;j<=i;j++){
			if((i+j*2)%n == 0){
				flag = 1;
				break;
			}
		}
		if(flag==1)break;
	}
	int n2=i-2;
	int n3,n1;
	n3=n1=j;
	length-=1;
	for(i=0;i<n1-1;i++){
		printf("%c",s1[i]);
		for(j=0;j<n2;j++){
			printf(" ");
		}
		printf("%c\n",s1[length-i]);
	}
	for(i=n1-1;i<=length-n1+1;i++){
		printf("%c",s1[i]);
	}
	printf("\n");
	return 0;
} 

  

posted @ 2017-10-20 08:52  gaoren  阅读(233)  评论(0编辑  收藏  举报