CY_

  博客园  :: 首页  :: 新随笔  :: 联系 :: 订阅 订阅  :: 管理


Problem Description

Oneof the first users of BIT's new supercomputer was Chip Diller. He extended hisexploration of powers of 3 to go from 0 to 333 and he explored taking varioussums of those numbers. 
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were hereto see these results.'' (Chip moved to a new apartment, once one becameavailable on the third floor of the Lemon Sky apartments on Third Street.) 

 

 

Input

Theinput will consist of at most 100 lines of text, each of which contains asingle VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters inlength, and will only contain digits (no VeryLongInteger will be negative). 

The final input line will contain a single zero on a line by itself.

 

 

Output

Yourprogram should output the sum of the VeryLongIntegers given in the input. 


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followedby N input blocks. Each input block is in the format indicated in the problemdescription. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line betweenoutput blocks.

 

 

Sample Input

1

 

 

123456789012345678901234567890

123456789012345678901234567890

123456789012345678901234567890

0

 

 

Sample Output

370370367037037036703703703670

 

 

Source

East Central North America 1996

参照前辈的, 用string写的一个高精度加法模板:

Code:

#include<iostream>
#include<string>
using namespace std;
string add(string x,string y)
{
    string ans ;
    int lenx = x.length();
    int leny = y.length();
    if(lenx<leny)
    {
        for(int i = 1;i<=leny-lenx;i++)
            x = "0"+x;
    }
    else
    {
        for(int i = 1;i<=lenx-leny;i++)
            y = "0"+y;
    }
    lenx = x.length();
    int cf = 0;
    int temp;
    for(int i = lenx-1;i>=0;i--)
    {
        temp = x[i] - '0' + y[i] - '0'+cf;
        cf = temp/10;
        temp%=10;
        ans = char('0'+temp)+ans;
    }
    if(cf!=0)
        ans = char(cf+'0')+ans;
    return ans;
}

int main()
{
    int t;
    string x,sum;
    cin>>t;
    while(t--)
    {
        sum = "0";
        while(cin>>x&&x!="0")
        {
            sum = add(sum,x);
        }
        cout<<sum<<endl;
        if(t>0)
            cout<<endl;
    }
}


posted on 2014-04-28 15:54  CY_  阅读(270)  评论(0编辑  收藏  举报