poj3046(Ant Counting)

Description

Bessie was poking around the ant hill one day watching the ants march to and fro while gathering food. She realized that many of the ants were siblings, indistinguishable from one another. She also realized the sometimes only one ant would go for food, sometimes a few, and sometimes all of them. This made for a large number of different sets of ants! 

Being a bit mathematical, Bessie started wondering. Bessie noted that the hive has T (1 <= T <= 1,000) families of ants which she labeled 1..T (A ants altogether). Each family had some number Ni (1 <= Ni <= 100) of ants. 

How many groups of sizes S, S+1, ..., B (1 <= S <= B <= A) can be formed? 

While observing one group, the set of three ant families was seen as {1, 1, 2, 2, 3}, though rarely in that order. The possible sets of marching ants were: 

3 sets with 1 ant: {1} {2} {3} 
5 sets with 2 ants: {1,1} {1,2} {1,3} {2,2} {2,3} 
5 sets with 3 ants: {1,1,2} {1,1,3} {1,2,2} {1,2,3} {2,2,3} 
3 sets with 4 ants: {1,2,2,3} {1,1,2,2} {1,1,2,3} 
1 set with 5 ants: {1,1,2,2,3} 

Your job is to count the number of possible sets of ants given the data above. 

Input

* Line 1: 4 space-separated integers: T, A, S, and B 

* Lines 2..A+1: Each line contains a single integer that is an ant type present in the hive

Output

* Line 1: The number of sets of size S..B (inclusive) that can be created. A set like {1,2} is the same as the set {2,1} and should not be double-counted. Print only the LAST SIX DIGITS of this number, with no leading zeroes or spaces.

Sample Input

3 5 2 3
1
2
2
1
3

Sample Output

10

设dp[i+1][j]表示从前i个物品中取出j个的方法数,则dp[i+1][j]=sigma(dp[i][j-k]),k=0...min(j,a[i]),直接计算的话时间复杂度太高,可以化简为dp[i+1][j]=dp[i+1][j-1]+dp[i][j]-dp[i][j-1-num[i]]。还可以进行空间优化,用dp[0][j]表示dp[i][j],用dp[1][j]表示dp[i+1][j]

未优化的代码:

#include <iostream>
#include <sstream>
#include <fstream>
#include <string>
#include <map>
#include <vector>
#include <list>
#include <set>
#include <stack>
#include <queue>
#include <deque>
#include <algorithm>
#include <functional>
#include <iomanip>
#include <limits>
#include <new>
#include <utility>
#include <iterator>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cctype>
#include <cmath>
#include <ctime>
using namespace std;

const int MOD = 1000000;
int t, a, s, b;
int num[1010], dp[1010][10010];

int main()
{
    cin >> t >> a >> s >> b;
    while (a--)
    {
        int type;
        scanf("%d", &type);
        num[type-1]++;
    }
    for (int i = 0; i <= t; ++i)
        dp[i][0] = 1;
    for (int i = 0; i < t; ++i)
        for (int j = 1; j <= b; ++j)
            if (j > num[i])
                dp[i+1][j] = (dp[i+1][j-1] + dp[i][j] - dp[i][j-1-num[i]] + MOD) % MOD;
            else
                dp[i+1][j] = (dp[i+1][j-1] + dp[i][j]) % MOD;
    int ans = 0;
    for (int i = s; i <= b; ++i)
        ans = (ans + dp[t][i]) % MOD;
    cout << ans << endl;
    return 0;
}
优化过后的代码:

#include <iostream>
#include <sstream>
#include <fstream>
#include <string>
#include <map>
#include <vector>
#include <list>
#include <set>
#include <stack>
#include <queue>
#include <deque>
#include <algorithm>
#include <functional>
#include <iomanip>
#include <limits>
#include <new>
#include <utility>
#include <iterator>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cctype>
#include <cmath>
#include <ctime>
using namespace std;

const int MOD = 1000000;
int t, a, s, b;
int num[1010], dp[2][10010];

int main()
{
    cin >> t >> a >> s >> b;
    while (a--)
    {
        int type;
        scanf("%d", &type);
        num[type-1]++;
    }
    for (int i = 0; i <= t; ++i)
        dp[0][0] = dp[1][0] = 1;
    for (int i = 0; i < t; ++i)
    {
        for (int j = 1; j <= b; ++j)
            if (j > num[i])
                dp[1][j] = (dp[1][j-1] + dp[0][j] - dp[0][j-1-num[i]] + MOD) % MOD;
            else
                dp[1][j] = (dp[1][j-1] + dp[0][j]) % MOD;
        for (int j = 1; j <= b; ++j)
            dp[0][j] = dp[1][j];
    }
    int ans = 0;
    for (int i = s; i <= b; ++i)
        ans = (ans + dp[1][i]) % MOD;
    cout << ans << endl;
    return 0;
}




posted on 2020-01-17 01:03  godweiyang  阅读(96)  评论(0编辑  收藏  举报

导航