Fibonacci Again

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 43312    Accepted Submission(s): 20674


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
0 1 2 3 4 5
 

Sample Output
no no yes no no no
 


 

 

 

#include<stdio.h>
main()
{
 int a,b,i,j;
 while(scanf("%d",&a)!=EOF)
 {
  if((a-2)%4==0)
  printf("yes\n");
  else printf("no\n");
 }
 return 0;
}

posted on 2016-04-08 11:19  gcczhongduan  阅读(102)  评论(0编辑  收藏  举报