HDU 2845 Beans(dp)

Problem Description
Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.


Now, how much qualities can you eat and then get ?

 

Input
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M*N<=200000.
 

Output
For each case, you just output the MAX qualities you can eat and then get.
 

Sample Input
4 6 11 0 7 5 13 9 78 4 81 6 22 4 1 40 9 34 16 10 11 22 0 33 39 6
 

Sample Output
242
 

Source
 

思路:注意状态转移方程。还有就是行的转移方程和列的相似。还有注意的是数组开大点


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

#define N 200005

int dpx[N],dpy[N];

int main()
{
    int n,m,i,j,s;

    while(~scanf("%d%d",&n,&m))
    {
        memset(dpx,0,sizeof(dpx));
        memset(dpy,0,sizeof(dpy));

        for(i=2;i<=n+1;i++)
        {

             //memset(dpy,0,sizeof(dpy));
             //这里为什么能够凝视掉呢,由于会被覆盖
             
             for(j=2;j<=m+1;j++)
            {
                scanf("%d",&s);
                dpy[j]=max(dpy[j-1],dpy[j-2]+s);  //dpy表示这一行从左到右能取到的最大的数和
            }
            dpx[i]=max(dpx[i-1],dpx[i-2]+dpy[1+m]);  //dpx表示从以上行中能取到数的最大的和
        }

        printf("%d\n",dpx[n+1]);
    }
    return 0;
}






版权声明:本文博客原创文章,博客,未经同意,不得转载。

posted on 2015-07-17 19:51  gcczhongduan  阅读(134)  评论(0编辑  收藏  举报