HDU 1671 (字典树统计是否有前缀)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1671


Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
NO YES
 

Source

题意:

统计是否有同样的前缀!

代码例如以下:

#include <cstdio>
#include <cstring>
#include <malloc.h>
#include <iostream>
using namespace std;
#define MAXN 10
typedef struct Trie
{
    int v;//依据须要变化
    Trie *next[MAXN];
    //next是表示每层有多少种类的数,假设仅仅是小写字母,则26就可以,
    //若改为大写和小写字母,则是52,若再加上数字,则是62了
}Trie;
Trie* root;

void createTrie(char *str)
{
    int len = strlen(str);
    Trie *p = root, *q;
    for(int i = 0; i < len; i++)
    {
        int id = str[i]-'0';
        if(p->next[id] == NULL)
        {
            q = (Trie *)malloc(sizeof(Trie));
            q->v = 1;//初始v==1
            for(int j = 0; j < MAXN; j++)
                q->next[j] = NULL;
            p->next[id] = q;
            p = p->next[id];
        }
        else
        {
        //    p->next[id]->v++;
            p = p->next[id];
        }
    }
     p->v = -1;//若为结尾,则将v改成-1表示
}

int findTrie(char *str)
{
    int len = strlen(str);
    Trie *p = root;
    for(int i = 0; i < len; i++)
    {
        int id = str[i]-'0';
        p = p->next[id];
        if(p == NULL) //若为空集,表示不存以此为前缀的串
            return 0;
        if(p->v == -1)   //字符集中已有串是此串的前缀
            return -1;
    }
    //return p->v;
    return -1;   //此串是字符集中某串的前缀
}
int dealTrie(Trie* T)
{
    //动态字典树,有时会超内存,这是就要记得释放空间了
    if(T==NULL)
        return 0;
    for(int i = 0; i < MAXN; i++)
    {
        if(T->next[i]!=NULL)
            dealTrie(T->next[i]);
    }
    free(T);
    return 0;
}
int main()
{
    int t, n;
    char str[15];
    scanf("%d",&t);
    while(t--)
    {
        int flag = 0;
        root = (Trie *)malloc(sizeof(Trie));
        for(int i = 0; i < MAXN; i++)
            root->next[i] = NULL;
        scanf("%d",&n);
        for(int i = 0; i < n; i++)
        {
            scanf("%s",str);
            if(findTrie(str) == -1)
            {
                flag = 1;
                continue;
            }
            createTrie(str);
        }
        if(flag)
            printf("NO\n");
        else
            printf("YES\n");
        dealTrie(root);
    }
    return 0;
}


posted on 2015-03-27 14:08  gcczhongduan  阅读(135)  评论(0编辑  收藏  举报