Ionic CLI升级到3版本后2版本工程运行出错.md

1. 问题描述:

最近将Ionic的CLI升级到了最新的版本3.2,升级后在原来Ionic2版本的CLI中创建的工程,通过ionic serve运行报错,错误类似如下:

C:\Users\Admin\myapp>ionic serve -l
[ERROR] Error occurred while loading plugins. CLI functionality may be limited.
**Checking for CLI updates now...**
[ERROR] No updates found after plugin error--please report this issue.

2. 解决方案

根据提示看起来好像是因为Ionic CLI需要更新似的,但是再更新是没有效果的,经过搜索,在网上找到如下解决方案:
在Ionic2版本CLI创建的工程目录下运行如下命令即可:

npm install --save-dev --save-exact @ionic/cli-plugin-ionic-angular@latest @ionic/cli-plugin-cordova@latest
posted @ 2017-05-19 08:34  Gavin·Gong  阅读(1641)  评论(1编辑  收藏