[转]如何将高版本的SQL Server数据库备份到低版本的SQL Server

本文转自:https://blog.csdn.net/wang465745776/article/details/54969676

前提条件
备份SQL Server服务器版本为:12.0.2000.8(SQL Server2014)
具体信息为:
Microsoft SQL Server Management Studio 12.0.2000.8
Microsoft Analysis Services Client Tools 12.0.2000.8
Microsoft Data Access Components (MDAC) 6.3.9600.16384
Microsoft MSXML 3.0 6.0
Microsoft Internet Explorer 9.11.9600.17416
Microsoft .NET Framework 4.0.30319.34014
Operating System 6.3.9600
还原数据库版本为:11.0.2100.60(SQL Server2012)
具体信息为:
Microsoft SQL Server Management Studio 11.0.2100.60
Microsoft Analysis Services 客户端工具 11.0.2100.60
Microsoft 数据访问组件 (MDAC) 6.1.7601.17514
Microsoft MSXML 3.0 6.0
Microsoft Internet Explorer 9.11.9600.18537
Microsoft .NET Framework 4.0.30319.42000
操作系统 6.1.7601
使用网上所讲的降低数据库兼容的方法之后,也备份不成功
错误信息为:
标题: Microsoft SQL Server Management Studio
备份介质验证失败: GAMS-Full Database Backup [文件: ] (Microsoft.SqlServer.Management.RelationalEngineTasks)
其他信息:
执行 Transact-SQL 语句或批处理时发生了异常。 (Microsoft.SqlServer.Smo)
该数据库是在运行版本 12.00.2000 的服务器上备份的。该版本与此服务器(运行版本 11.00.2100)不兼容。请在支持该备份的服务器上还原该数据库,或者使用与此服务器兼容的备份。
VERIFY DATABASE 正在异常终止。 (Microsoft SQL Server,错误: 3169)
有关帮助信息,请单击:
操作步骤
连接上服务器
选中要备份的数据库,右键选择Tasks->Genetate Scripts…
直接Next

直接Next

选择Advanced

设置执行SQL的服务器版本和导出的内容

选择导出SQL要保存的位置

直接Next

点击Finish

重点来了,我就在这里卡了很久。生成的SQL用还原服务器打开,把语句中保持数据库文件和日志文件的路径根据SQL Server的安装路径进行修改

按F5执行语句,如果没有报错,那么就成功了

其他
如果你发现了如何从降低SQL Server数据库兼容版本来达到相同目的,请留言告诉我,谢谢
---------------------
作者:自由堂
来源:CSDN
原文:https://blog.csdn.net/wang465745776/article/details/54969676
版权声明:本文为博主原创文章,转载请附上博文链接!

 

posted on 2019-02-12 16:32  freeliver54  阅读(...)  评论(... 编辑 收藏

导航