ElasticSearch安装
1.1 安装ES&Kibana
yml文件
version
踩坑日记:
打印日志: docker-compose logs -f
ES安装后会报错内存不足:78错
`报错“max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]”`查看当前值:
sysctl -a|grep vm.max_map_count
解决办法;修改虚拟机的配置文件
1:临时修改:
sysctl -w vm.max_map_count=262144
2:长久修改:
vi /etc/sysctl.conf
在最后面加上如下代码
vm.max_map_count=655360(报错连接值不足262144) 要求这个值大于262144
执行命令:使文件重新生效
sysctl -p
1.2 安装IK分词器
由于网络问题,采用国内的路径去下载:http://tomcat01.qfjava.cn:81/elasticsearch-analysis-ik-6.5.4.zip
http://192.168.171.100:8080/elasticsearch-analysis-ik-6.5.4.zip
进去到ES容器内部,跳转到bin目录下,执行bin目录下的脚本文件:
./elasticsearch-plugin install http://192.168.1.33:8080/elasticsearch-analysis-ik-6.5.4.zip
重启ES的容器,让IK分词器生效。

本文来自博客园,作者:forever226,转载请注明原文链接:https://www.cnblogs.com/forever226/p/16504064.html


浙公网安备 33010602011771号