ElasticSearch安装

1.1 安装ES&Kibana

yml文件

version: "3.1"
services:
elasticsearch:
  image: daocloud.io/library/elasticsearch:6.5.4
  restart: always
  container_name: elasticsearch
  ports:
    - 9200:9200
kibana:
  image: daocloud.io/library/kibana:6.5.4
  restart: always
  container_name: kibana
  ports:
    - 5601:5601
  environment:
    - elasticsearch_url=http://192.168.199.109:9200
  depends_on:
    - elasticsearch

踩坑日记:

 

打印日志: docker-compose logs -f

 

ES安装后会报错内存不足:78错

`报错“max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]”`

查看当前值:

sysctl -a|grep vm.max_map_count

 

解决办法;修改虚拟机的配置文件

1:临时修改:

sysctl -w vm.max_map_count=262144

2:长久修改:

vi /etc/sysctl.conf

在最后面加上如下代码

vm.max_map_count=655360(报错连接值不足262144) 要求这个值大于262144

执行命令:使文件重新生效

sysctl -p

 

1.2 安装IK分词器

 

posted @ 2022-07-21 23:38  forever226  阅读(45)  评论(0)    收藏  举报