相对而不绝对

  博客园  :: 首页  :: 新随笔  :: 联系 :: 订阅 订阅  :: 管理

     前一段时间产品出现因第三方库低版本的不兼容现象,如何处理不兼容现象,在另一篇文章里提到。

    找到了两种方式找出不兼容的原因,第一种是低版本的真机,第二种是增加模拟器里的低版本操作系统的设备。在这儿第一种就不多细说,详细讲解第二种的操作步骤。

    第一步:点击到模拟器界面,点击Hardware里的Device,然后点击Manage Devices... 操作如下图1.1 ,结果如下图1.2:

       

                                     图1.1                                                                                    图1.2

    第二步:在上图1.2上点击左下角的“+”按钮增加模拟器,弹出如下图1.3所示,点击OS Version 弹出Download more simulator runtimes...,点击之后如下图1.4所示,弹出下载列表

      

 

                                                           图1.3                                                                                                                                                                图1.4 

  第三步:下载完成之后点击上图1.4的右下角的Check and install Now按钮,就安装完成了,然后就可以在Xcode运行时选择了,如下图1.5所示,到此大功告成。

                                         图1.5

posted on 2017-09-01 16:40  相而勿绝  阅读(1173)  评论(0编辑  收藏  举报