免费将Mac OS X从Snow Leopard升级到Mountain Lion


  最近Apple发布了Mac OS X Mountain Lion(10.8版),看到偶的Mac还是10.6,于是考虑升级。下面是升级过程中碰到的一些问题整理。

系统升级
1、升级条件
  升级需要满足的硬件条件
    iMac (2007年年中,或者更新的产品)
    MacBook (2008晚期, 2009年,或者更新的产品)
    MacBook Pro (2007年年中或者晚期,或者更新的产品)
    MacBook Air (2008年晚期,或者更新的产品)
    Mac mini (2009年初,或者更新的产品)
    Mac Pro (2008年初,或者更新的产品)
    Xserve (2009年初)
  升级需要满足的软件条件
        当前软件为Snow Leopard 10.6.8或以上版本

2、升级方式
     方式一:在Mac App Store直接购买,19.99美刀
     方式二:下载升级安装包(附:BT种子),免费!这里主要讲这种方式

    下载后得到一个4.1GB左右的安装包OS X Mountain Lion DP GM.dmg,打开安装包,可以找到一个Install OS X Mountain Lion.app的安装文件,右键显示包内容,找到目录下的文件 Contents/SharedSupport/InstallESD.dmg,使用openssl md5查看InstallESD.dmg文件的MD5码(例如执行命令行:openssl md5 ~/Downloads/Install\ OS\ X\ Mountain\ Lion.app/Contents/SharedSupport/InstallESD.dmg),看看是否正确,如果为“8b4869920cd740414fe6b7e3f0b1be3e”,则是正常的,可以放心安装。

    安装时,不要直接运行Install OS X Mountain Lion.app,而是运行上面说的InstallESD.dmg,这样才能避开Apple的购买检查,正常安装。


软件设置
  升级成功后,许多地方还要重新设置的,主要有如下点:

  1、系统偏好设置-安全性与隐私,“允许从以下位置下载应用程序”,默认设置为“Mac App Store和被认可的开发者”,最好改为“任何来源”,否则一些程序将无法启动。


  2、原来的Apache、PHP配置都会被覆盖,需要重新配置。
    Apache配置文件:/etc/apache2/httpd.conf (系统共享里少了“Web共享”,但Apache还是可以使用的)
    PHP配置文件:/etc/php.ini,(值得一提的是,此次PHP编译时就带了更多的扩展,如pdo_mysql等不需要自行编译安装)
  3、java环境被删除,Adobe CS5、Eclipse等基于Java开发的软件,无法使用,提示安装Java。按照指引安装Java SE 6,如果安装失败,可在这边自行下载安装Java SE 6:http://www.macupdate.com/app/mac/39490/apple-java-for-os-x-lion/

新功能

     升级后,使用过程中,感触最深的就是这三点变化: 

  1、通知中心,更接近iOS
  2、iMessage取代iChat,与iOS通信更自由
  3、Safari变化较大
  

posted @ 2012-07-30 00:06  canbeing  阅读(11051)  评论(7编辑  收藏