Drainage Ditches

Description

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.  Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.  Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50
题意:求一个起点到终点的最大流。
题解:多次bfs找增广流直到没有增广流为止
#include<stdio.h>
#include<iostream>
#include<queue>
#include<string.h>
#define INF 10000000
using namespace std;
int p[205][205];
int path[205];//保存增广路径
int flow[205];
int n,m,s;
int min(int a,int b)
{
 return a<b?a:b;
}
queue<int> q;
int bfs(int s)
{
 int i;
 while(!q.empty()) q.pop();
 memset(path,-1,sizeof(path));
 path[s]=0;
 flow[s]=INF;
 q.push(s);
 while(!q.empty())
 {
       int t=q.front();
    q.pop();
    for(i=1;i<=m;i++)
    {
     if(i!=s&&path[i]==-1&&p[t][i])
     {
      flow[i]=min(flow[t],p[t][i]);
      path[i]=t;
      q.push(i);
     }
    }
 }
    if(path[m]==-1) return -1;
 return flow[m];
}
int finder()
{
  int maxi=0,cur,pre,step;
  while((step=bfs(s))!=-1)
  {
   maxi+=step;
      cur=m;
   while(cur!=s)
   {
    pre=path[cur];
    p[pre][cur]-=step;
    p[cur][pre]+=step;
    cur=pre;
   }
  }
  return maxi;
}
int main()
{
    int i;
 while(scanf("%d %d",&n,&m)!=EOF)
 {
  int a,b,c;
  memset(p,0,sizeof(p));
  for(i=1;i<=n;i++)
  {
   scanf("%d %d %d",&a,&b,&c);
   p[a][b]+=c;
  }
  s=1;
        printf("%d\n",finder());
 }
 return 0;
}
posted @ 2013-10-11 17:48  forevermemory  阅读(217)  评论(0编辑  收藏  举报