AreYouBusy

Problem Description
Happy New Term! As having become a junior, xiaoA recognizes that there is not much time for her to AC problems, because there are some other things for her to do, which makes her nearly mad. What's more, her boss tells her that for some sets of duties, she must choose at least one job to do, but for some sets of things, she can only choose at most one to do, which is meaningless to the boss. And for others, she can do of her will. We just define the things that she can choose as "jobs". A job takes time , and gives xiaoA some points of happiness (which means that she is always willing to do the jobs).So can you choose the best sets of them to give her the maximum points of happiness and also to be a good junior(which means that she should follow the boss's advice)?
 
Input
There are several test cases, each test case begins with two integers n and T (0<=n,T<=100) , n sets of jobs for you to choose and T minutes for her to do them. Follows are n sets of description, each of which starts with two integers m and s (0<m<=100), there are m jobs in this set , and the set type is s, (0 stands for the sets that should choose at least 1 job to do, 1 for the sets that should choose at most 1 , and 2 for the one you can choose freely).then m pairs of integers ci,gi follows (0<=ci,gi<=100), means the ith job cost ci minutes to finish and gi points of happiness can be gained by finishing it. One job can be done only once.
 
Output
One line for each test case contains the maximum points of happiness we can choose from all jobs .if she can’t finish what her boss want, just output -1 .
 
Sample Input
3 3 2 1 2 5 3 8 2 0 1 0 2 1 3 2 4 3 2 1 1 1 3 4 2 1 2 5 3 8 2 0 1 1 2 8 3 2 4 4 2 1 1 1 1 1 1 0 2 1 5 3 2 0 1 0 2 1 2 0 2 2 1 1 2 0 3 2 2 1 2 1 1 5 2 8 3 2 3 8 4 9 5 10
 
Sample Output
5 13 -1 -1
题意:给定n种工作,某类工作至少选一个,某类工作最多选一个,某类工作可以任意选择。每个工作都有时间花费与价值,给定一个时间初始值,求最大价值量
p[i][j],i表示工作组,j表示时间
#include<stdio.h>
#include<iostream>
#include<string.h>
#define ll 10000000
using namespace std;
int n,t,m,s;
int p[101][101];
int cost[101];
int val[101];
int maxi(int a,int b)
{
 return a>b?a:b;
}
int main()
{
 int i,j,k;
    while(scanf("%d %d",&n,&t)!=EOF)
 {
  memset(p,0,sizeof(p));
       for(i=1;i<=n;i++)
    {
     scanf("%d %d",&m,&s);
           for(j=1;j<=m;j++)
     {
      scanf("%d %d",&cost[j],&val[j]);
     }
     if(s==0)
     {
               for(j=0;j<=t;j++) p[i][j]=-ll;
      for(j=1;j<=m;j++)
      {
       for(k=t;k>=cost[j];k--)
       {
           p[i][k]=maxi(p[i][k],maxi(p[i-1][k-cost[j]],p[i][k-cost[j]])+val[j]);
       }
      }
     }
     else if(s==1)
     {
      for(j=0;j<=t;j++) p[i][j]=p[i-1][j];
      for(j=1;j<=m;j++)
      {
       for(k=t;k>=cost[j];k--)
       {
        p[i][k]=maxi(p[i][k],p[i-1][k-cost[j]]+val[j]);
       }
      }
     }
     else if(s==2)
     {
      for(j=0;j<=t;j++) p[i][j]=p[i-1][j];
      for(j=1;j<=m;j++)
      {
       for(k=t;k>=cost[j];k--)
       {
        p[i][k]=maxi(p[i][k],p[i][k-cost[j]]+val[j]);
       }
      }
     }
    }
    p[n][t]=maxi(-1,p[n][t]);
    printf("%d\n",p[n][t]);
 }
 return 0;
}
posted @ 2013-10-07 18:56  forevermemory  阅读(426)  评论(0编辑  收藏  举报