i love sneakers

Problem Description
After months of hard working, Iserlohn finally wins awesome amount of scholarship. As a great zealot of sneakers, he decides to spend all his money on them in a sneaker store.
There are several brands of sneakers that Iserlohn wants to collect, such as Air Jordan and Nike Pro. And each brand has released various products. For the reason that Iserlohn is definitely a sneaker-mania, he desires to buy at least one product for each brand. Although the fixed price of each product has been labeled, Iserlohn sets values for each of them based on his own tendency. With handsome but limited money, he wants to maximize the total value of the shoes he is going to buy. Obviously, as a collector, he won’t buy the same product twice. Now, Iserlohn needs you to help him find the best solution of his problem, which means to maximize the total value of the products he can buy.
 
Input
Input contains multiple test cases. Each test case begins with three integers 1<=N<=100 representing the total number of products, 1 <= M<= 10000 the money Iserlohn gets, and 1<=K<=10 representing the sneaker brands. The following N lines each represents a product with three positive integers 1<=a<=k, b and c, 0<=b,c<100000, meaning the brand’s number it belongs, the labeled price, and the value of this product. Process to End Of File.
 
Output
For each test case, print an integer which is the maximum total value of the sneakers that Iserlohn purchases. Print "Impossible" if Iserlohn's demands can’t be satisfied.
 
Sample Input
5 10000 3 1 4 6 2 5 7 3 4 99 1 55 77 2 44 66
 
Sample Output
255
题意:k类运动鞋,每双鞋都有他的价钱和价值,给定有一定数量的钱,要求每类至少买一件求是否能将钱花光并且获取最大的价值
题解:分组背包,设f[i][j],i表示鞋的分类,j表示价钱。
#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
int p[105][105];
int pp[105][105];
int des[105];
int sum[12][10005];
int n,v,g;
int maxi(int a,int b)
{
 return a>b?a:b;
}
int main()
{
 int i,j,k,l,a,b,c;
     while(scanf("%d %d %d",&n,&v,&g)!=EOF)
  {
   memset(p,0,sizeof(p));
   memset(pp,0,sizeof(pp));
   memset(des,0,sizeof(des));
   memset(sum,-1,sizeof(sum));
   for(i=0;i<=v;i++) sum[0][i]=0;
   for(i=0;i<n;i++)
   {
    scanf("%d %d %d",&a,&b,&c);
             p[a][des[a]]=b;
    pp[a][des[a]++]=c;
   }
         for(k=1;k<=g;k++)
   {
    for(j=0;j<des[k];j++)
    {
     for(i=v;i>=p[k][j];i--)
     {
                    sum[k][i]=maxi(sum[k][i],maxi(sum[k][i-p[k][j]],sum[k-1][i-p[k][j]])+pp[k][j]);
     }
    }
   }
   if(sum[g][v]==-1) puts("Impossible");
   else  printf("%d\n",sum[g][v]);
  }
 return 0;
}
posted @ 2013-10-07 11:39  forevermemory  阅读(209)  评论(0编辑  收藏  举报