2013年成都赛区网络赛之水题A Bit Fun

Problem Description
There are n numbers in a array, as a0, a1 ... , an-1, and another number m. We define a function f(i, j) = ai|ai+1|ai+2| ... | aj . Where "|" is the bit-OR operation. (i <= j) The problem is really simple: please count the number of different pairs of (i, j) where f(i, j) < m.
 
Input
The first line has a number T (T <= 50) , indicating the number of test cases. For each test case, first line contains two numbers n and m.(1 <= n <= 100000, 1 <= m <= 230) Then n numbers come in the second line which is the array a, where 1 <= ai <= 230.
 
Output
For every case, you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then follows the answer.
 
Sample Input
2 3 6 1 3 5 2 4 5 4
 
Sample Output
Case #1: 4 Case #2: 0
题意:给定n个数字,相邻数字进行异或操作,求满足操作的和小于某个数m的数量
题解:随着异或数字的增多,操作值必然越来越大。暴力求解
#include<stdio.h>
int p[100005];
int main()
{
    int test,n,i,ca=0,j,m;
 scanf("%d",&test);
 while(test--)
 {
  ca++;
  int cnt=0;
  scanf("%d %d",&n,&m);
  for(i=0;i<n;i++)
  {
   scanf("%d",&p[i]);
  }
  printf("Case #%d: ",ca);
        for(i=0;i<n;i++)
  {
   int t=p[i];
   for(j=i;j<n;j++)
   {
               t=t|p[j];
      if(t<m) cnt++;
      else break;
   }
  }
  printf("%d\n",cnt);
 }
 return 0;
}
posted @ 2013-09-15 10:25  forevermemory  阅读(262)  评论(0编辑  收藏  举报