Beat

Problem Description

Zty is a man that always full of enthusiasm. He wants to solve every kind of difficulty ACM problem in the world. And he has a habit that he does not like to solve
a problem that is easy than problem he had solved. Now yifenfei give him n difficulty problems, and tell him their relative time to solve it after solving the other one.
You should help zty to find a order of solving problems to solve more difficulty problem.
You may sure zty first solve the problem 0 by costing 0 minute. Zty always choose cost more or equal time’s problem to solve.

Input

The input contains multiple test cases.
Each test case include, first one integer n ( 2< n < 15).express the number of problem.
Than n lines, each line include n integer Tij ( 0<=Tij<10), the i’s row and j’s col integer Tij express after solving the problem i, will cost Tij minute to solve the problem j.

Output

For each test case output the maximum number of problem zty can solved.


Sample Input

3
0 0 0
1 0 1
1 0 0
3
0 2 2
1 0 1
1 1 0
5
0 1 2 3 1
0 0 2 3 1
0 0 0 3 1
0 0 0 0 2
0 0 0 0 0

Sample Output

3
2
4
题意:给定一个二维图,求出一个最大的序列满足后一个元素比前一个元素要大,至于为什么都要从第一个开始搜,还没想清楚。
AC代码:
#include<stdio.h>
#include<string.h>
int p[20][20];
bool visit[20];
int n,ma;
void dfs(int s,int k,int m)
{
    int i;
    for(i=0;i<n;i++)
    {
        if(k+1>ma) ma=k+1;
        if(visit[i]==0&&p[s][i]>=m)
        {
            visit[i]=1;
            dfs(i,k+1,p[s][i]);
            visit[i]=0;
        }
    }
}
int main()
{
    int i,j;
    while(scanf("%d",&n)!=EOF)
    {
        for(i=0;i<n;i++)
        {
            for(j=0;j<n;j++)
            {
                scanf("%d",&p[i][j]);
            }
        }
        memset(visit,0,sizeof(visit));
        ma=0;
        visit[0]=1;
        dfs(0,0,0);
        printf("%d\n",ma);
    }
    return 0;
}
posted @ 2013-08-12 08:57  forevermemory  阅读(309)  评论(1编辑  收藏  举报