linux下升级gcc版本(gcc-7)

ubuntu16.04的自带gcc版本为gcc-5,因为安装pl-slam的需要升级到gcc-7,可以通过以下命令查看你的gcc版本

gcc --version

通过apt工具对gcc进行升级

 1 sudo add-apt-repository ppa:ubuntu-toolchain-r/test 2 sudo apt-get update 3 sudo apt-get install -y g++-7 

然后还需要对gcc进行更换软连接

cd /usr/bin #进入/usr/bin文件夹下
sudo rm -r gcc #移除之前的软连接 
sudo ln -sf gcc-7 gcc #建立gcc4.7的软连接 
sudo rm -r g++ #同gcc 
sudo ln -sf g++-7 g++

在查看gcc的版本

参考:

https://blog.csdn.net/betty13006159467/article/details/78394974

posted @ 2018-09-24 15:59 feifanren 阅读(...) 评论(...) 编辑 收藏