POJ 2524 Ubiquitous Religions 解题报告

Ubiquitous Religions
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 34122   Accepted: 16477

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

Hint

Huge input, scanf is recommended.

Source

Alberta Collegiate Programming Contest 2003.10.18

题解

再来并查集,作为并查集学习的专题吧,这这道题考察连通块的个数,道题较为基础,每次合并的时候加入计数一次就好,但是要是没加到图里面的点才能计数,这样直接用总的点数减去它即可得到连通块的个数

#include <iostream>
#include <cstdio>

const int maxn = 1e6+7;

using namespace std;

int father[maxn];
int cnt = 0;

void init()
{
    cnt = 0;
    for (int i=0; i<maxn; i++)
        father[i] = i;
}

int fi(int x)
{
    return x == father[x] ? x : father[x] = fi(father[x]);
}

void unite(int x, int y)
{
    int p1 = fi(x), p2 = fi(y);
    if (p1 == p2) return;
    father[p1] = p2;
    cnt++;
}

bool same(int x, int y)
{
    if (fi(x) == fi(y))
        return true;
    return false;
}

int main()
{
    int n, m, a, b, c = 1;
    while (~scanf("%d%d", &n ,&m))
    {
        init();
        if (n == 0 && m == 0) break;
        while (m--)
        {
            scanf("%d%d", &a, &b);
            unite(a, b);
        }

        printf("Case %d: %d\n", c++, n-cnt);
    }
    return 0;
}


posted @ 2017-04-14 01:46  范晋豪  阅读(225)  评论(0编辑  收藏  举报