POJ 2593 Max Sequence

Max Sequence
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 17678   Accepted: 7401

Description

Give you N integers a1, a2 ... aN (|ai| <=1000, 1 <= i <= N). 

You should output S. 

Input

The input will consist of several test cases. For each test case, one integer N (2 <= N <= 100000) is given in the first line. Second line contains N integers. The input is terminated by a single line with N = 0.

Output

For each test of the input, print a line containing S.

Sample Input

5
-5 9 -5 11 20
0

Sample Output

40

Source

POJ Monthly--2005.08.28,Li Haoyuan


题解:这个题2479差不多,具体可以看2479的题解,不过感觉这道题的测试数据要比2479弱一些,轻松AC

//主要是刷几道dp练练手

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

const int maxn = 1e6+7, inf = -1e9+7;
int a[maxn], ls[maxn], rs[maxn], rst[maxn], s;

int main()
{
    int n;
    while (~scanf("%d", &n) && n)
    {
        for (int i=0; i<n; i++)
            scanf("%d", &a[i]);
        ls[0] = a[0], rs[n-1] = rst[n-1] = a[n-1], s = inf;
        for (int i=1; i<n; i++)
            ls[i] = max(ls[i-1]+a[i], a[i]);
        for (int i=n-2; i>=0; i--)
            rs[i] = max(rs[i+1]+a[i], a[i]),
            rst[i] = max(rst[i+1], rs[i]);
        for (int i=1; i<n; i++)
            s = max(s, ls[i-1]+rst[i]);
        printf("%d\n", s);
    }
    return 0;
}


posted @ 2017-04-15 22:39  范晋豪  阅读(160)  评论(0编辑  收藏  举报