Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 37467 Accepted Submission(s): 17166

Problem Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X= < x 1, x2, …, xm> another sequence Z = < z1, z2, …, zk> is a subsequence of X if there exists a strictly increasing sequence < i1, i2, …, ik> of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = < a, b, f, c> is a subsequence of X =< a ,b,c , f, b , c > with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc abfcab
programming contest
abcd mnp

Sample Output

4
2
0

简单的二维上的动态规划 LCS 求最长公共子序列

#include <iostream>
#include <cstdio>
#include <string.h>
using namespace std;
const int n=1000;
int arr[n][n];
int max(int num1,int num2) {
    return num1>num2?num1:num2;
}
int main() {
    char a[n],b[n];

    while(scanf("%s%s",a,b)!=EOF) {
        int len1=strlen(a);
        int len2=strlen(b);
        for(int i=1; i<=len1; i++)
            for(int j=1; j<=len2; j++) {
                if(a[i-1]==b[j-1])
                    arr[i][j]=arr[i-1][j-1]+1;
                if(a[i-1]!=b[j-1])
                    arr[i][j]=max(arr[i-1][j],arr[i][j-1]);
            }
        cout<<arr[len1][len2]<<endl;

    }

    return 0;
}