Knight Moves
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 25909 Accepted: 12244
Description

Background
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him?
The Problem
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov.
For people not familiar with chess, the possible knight moves are shown in Figure 1.

Input

The input begins with the number n of scenarios on a single line by itself.
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, …, l-1}*{0, …, l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.
Output

For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.
Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1
Sample Output

5
28
0
Source

TUD Programming Contest 2001, Darmstadt, Germany

具体的可能会有DFS的减枝优化,我没有试,仔细一想,正常的DFS应该都会超时吧,用BFS广度优先搜索

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <queue>
using namespace std;
int mark[400][400];
int next[9][2]= {{-2,1},{-1,2},{1,2},{2,1},{2,-1},{1,-2},{-1,-2},{-2,-1}};
int startx,starty,p,q,len;
struct node {
    int x;
    int y;
    int step;
};
int main() {

    int t;
    cin>>t;
    while(t--) {
        queue<node> que;
        memset(mark,0,sizeof(mark));
        if(!que.empty()) que.pop();
        cin>>len>>startx>>starty>>p>>q;
        mark[startx][starty]=1;
        node one;
        one.x=startx;
        one.y=starty;
        one.step=0;
        que.push(one);
        int flag=0;
        while(!que.empty()) {
            one=que.front();
            que.pop();
            if(one.x==p&&one.y==q) {
                cout<<one.step<<endl;
                break;
            }
            for(int i=0; i<8; i++) {
                node cur;
                cur.x=one.x+next[i][0];
                cur.y=one.y+next[i][1];
                if(cur.x<0||cur.x>len-1||cur.y<0||cur.y>len-1)
                    continue;
                if(mark[cur.x][cur.y]==0) {
                    cur.step=one.step+1;
                    mark[cur.x][cur.y]=1;
                    que.push(cur);
                }
            }
        }

    }
    return 0;
}

AC~~~