Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 49848 Accepted Submission(s): 15501

Problem Description
上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8。

Input
输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。
整个文件以两个-1结尾。

Output
对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出”Yes”,否则输出”No”。

Sample Input
6 8 5 3 5 2 6 4
5 6 0 0

8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0

3 8 6 8 6 4
5 3 5 6 5 2 0 0

-1 -1

Sample Output
Yes
Yes
No

两个限制条件
1.满足任意两点仅有一条路可以到达 即边的个数比点的个数少1
2.不存在闭环 。。这两点不兼容 因为可能存在孤立的点

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;
const int maxn=100005;
int f[maxn],a[maxn];
void init() {
    for(int i=0;i<maxn;i++) {
        f[i]=i;
    }
}
int getf(int x) {
    if(f[x]==x) return f[x];
    else {
        f[x]=getf(f[x]);
        return f[x];
    }
}
bool ismerge(int t1,int t2) {
    int m=getf(t1);
    int n=getf(t2);
    if(m!=n) {//之前两点不在一个集合 可以 
        f[n]=m;
        return false;
    }
    return true;
}
int main() {
    int x,y;
    while(scanf("%d%d",&x,&y),x!=-1&&y!=-1) {
        init();
        memset(a,0,sizeof(a));
        int ok=1;
        if(x==0&&y==0) {
            printf("Yes\n");
            continue;
        }
        f[y]=x;
        a[x]=1;
        a[y]=1;
        int edge=1;
        while(scanf("%d%d",&x,&y),x!=0&&y!=0) {
            a[x]=1;
            a[y]=1;
            if(!ismerge(x,y))
                edge++;
            else ok=0;//环 
        }
        int node=0;
        for(int i=0;i<maxn;i++) {
            if(a[i]) node++;
        }
        if(!ok) printf("No\n");//考虑闭环  
        else if(node-1==edge) printf("Yes\n");//考虑任意两点都有路 
        else printf("No\n");
    }
    return 0;
}