Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20404 Accepted Submission(s): 12231

Problem Description
The inversion number of a given number sequence a1, a2, …, an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, …, an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, …, an-1, an (where m = 0 - the initial seqence)
a2, a3, …, an, a1 (where m = 1)
a3, a4, …, an, a1, a2 (where m = 2)

an, a1, a2, …, an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

Output
For each case, output the minimum inversion number on a single line.

Sample Input
10
1 3 6 9 0 8 5 7 4 2

Sample Output
16

思路:先求出原序列的逆序对和,在递推求变换位置的和,取最小值,用线段树叶子维护0~n-1的值

#include <cstdio>
#include <iostream>
#include <algorithm>

using namespace std;
#define lson l,m,rt<<1 
#define rson m+1,r,rt<<1|1
const int maxn=5000+100;
int sum[maxn<<2];
void pushup(int rt) {
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void build(int l,int r,int rt) {
    sum[rt]=0;
    if(l==r) return ;
    int m=(l+r)>>1;
    build(lson);
    build(rson);//no need pushup all 0
}

void update(int p,int l,int r,int rt) {
    if(l==r) {
        sum[rt]=1;
        return ;
    }
    int m=(l+r)>>1;
    if(p<=m) update(p,lson);
    else update(p,rson);
    pushup(rt);
}
int query(int L,int R,int l,int r,int rt) {
    if(L<=l&&r<=R) {
        return sum[rt];
    }
    int m=(l+r)>>1;
    int ans=0;
    if(L<=m) ans+=query(L,R,lson);
    if(R>m) ans+=query(L,R,rson);
    return ans; 
}
int a[maxn];
int main() {
//  freopen("input.txt","r",stdin);
    int n;
    while(scanf("%d",&n)!=EOF) {
        int ans=0;
        build(0,n-1,1);
        for(int i=0;i<n;i++) {
            scanf("%d",&a[i]);
            ans+=query(a[i],n-1,0,n-1,1);
            update(a[i],0,n-1,1);
        }
        int ret=ans;
        for(int i=0;i<n;i++) {
            ans+=n-a[i]-a[i]-1;
            ret=min(ret,ans);
        }
        printf("%d\n",ret);
    }
    return 0;
}