摘要:查询分配太多小的extent的undo段。如果一个大查询分配到 太多小的extent的undo段的时候。就容易出现该错误IF: ORA-1628 Reported During Long Running Transactions (文档 ID 1951032.1)ORA-01628 errors i
阅读全文
摘要:ora-1000问题排查open_cursor.底层视图是从x$kgllk中来的。并且通过kglhdnsp = 0过滤了sp打开的cursor。会加1号null的易碎解析锁。可能的原因:1.执行的sql语句确实比较多(可能性比较小)。2.sp里面的循环硬解析造成的 1.查找哪些session当前打开
阅读全文
摘要:查找sp里面的哪条sql语句,消耗的buffer gets最多,或消耗时间最多的进行优化 select TO_CHAR(T.Begin_interval_time, 'MM-DD HH24:MI') BTIME, s.instance_number i_n, s.snap_id, s.sql_id,
阅读全文
摘要:--参考信息:故障排除:Shared Pool优化和Library Cache Latch冲突优化 (文档 ID 1523934.1) --注意:如果系统中有library cache latch争用的问题,下面的sql语句会导致争用加剧。SET pages 10000SET linesize 25
阅读全文
摘要:1.查看哪些sql语句占用的临时表空间空间最多。 select ash.TEMP_SPACE_ALLOCATED / 1024 / 1024 / 1024 G, ash.SESSION_ID, ash.SESSION_SERIAL#, ash.SQL_ID, ash.TOP_LEVEL_SQL_ID
阅读全文
摘要:1.使用语句监控应用帐号的normal索引 select owner, 'alter index ' || owner || '.'||'"'||index_name||'"'||' monitoring usage;' from dba_indexes where index_type = 'NO
阅读全文
摘要:desc:oracle检查某个表对象上的lock SELECT username, schemaname, se.MACHINE, se.MODULE, 'ALTER SYSTEM KILL SESSION ' || '''' || se.sid || ',' || se.serial# || ',
阅读全文