随笔分类 -  script

ora-1628,undo unable extend.的问题排查脚本
摘要:查询分配太多小的extent的undo段。如果一个大查询分配到 太多小的extent的undo段的时候。就容易出现该错误IF: ORA-1628 Reported During Long Running Transactions (文档 ID 1951032.1)ORA-01628 errors i 阅读全文

posted @ 2018-08-25 00:01 erwadba 阅读(1277) 评论(0) 推荐(0)

ora-1000问题排查
摘要:ora-1000问题排查open_cursor.底层视图是从x$kgllk中来的。并且通过kglhdnsp = 0过滤了sp打开的cursor。会加1号null的易碎解析锁。可能的原因:1.执行的sql语句确实比较多(可能性比较小)。2.sp里面的循环硬解析造成的 1.查找哪些session当前打开 阅读全文

posted @ 2018-08-23 13:03 erwadba 阅读(1413) 评论(0) 推荐(0)

怎样查找某个sp中哪条sql语句存在性能问题。
摘要:查找sp里面的哪条sql语句,消耗的buffer gets最多,或消耗时间最多的进行优化 select TO_CHAR(T.Begin_interval_time, 'MM-DD HH24:MI') BTIME, s.instance_number i_n, s.snap_id, s.sql_id, 阅读全文

posted @ 2017-12-15 09:47 erwadba 阅读(268) 评论(0) 推荐(0)

检查数据库内硬解析的sql语句
摘要:--参考信息:故障排除:Shared Pool优化和Library Cache Latch冲突优化 (文档 ID 1523934.1) --注意:如果系统中有library cache latch争用的问题,下面的sql语句会导致争用加剧。SET pages 10000SET linesize 25 阅读全文

posted @ 2017-12-15 09:36 erwadba 阅读(1115) 评论(0) 推荐(0)

临时表空间使用过大排查
摘要:1.查看哪些sql语句占用的临时表空间空间最多。 select ash.TEMP_SPACE_ALLOCATED / 1024 / 1024 / 1024 G, ash.SESSION_ID, ash.SESSION_SERIAL#, ash.SQL_ID, ash.TOP_LEVEL_SQL_ID 阅读全文

posted @ 2017-12-15 09:26 erwadba 阅读(296) 评论(0) 推荐(0)

oracle oltp系统索引使用监控
摘要:1.使用语句监控应用帐号的normal索引 select owner, 'alter index ' || owner || '.'||'"'||index_name||'"'||' monitoring usage;' from dba_indexes where index_type = 'NO 阅读全文

posted @ 2017-12-15 08:30 erwadba 阅读(218) 评论(0) 推荐(0)

lock检查
摘要:desc:oracle检查某个表对象上的lock SELECT username, schemaname, se.MACHINE, se.MODULE, 'ALTER SYSTEM KILL SESSION ' || '''' || se.sid || ',' || se.serial# || ', 阅读全文

posted @ 2017-12-15 08:17 erwadba 阅读(186) 评论(0) 推荐(0)

导航