tomcat内容总结
tomcat的安装以及配置环境变量
1.tomcat的官网下载地址:http://tomcat.apache.org/
tomcat有很多版本,有解压版 和 安装版,还分windows (还分为32位和64位版)和
linux版,根据自己的需求,选择对应的版本下载。
tomcat服务器运行需要jdk的支持,版本对应为:

2.tomcat是用java语言编写的,java语言编写的需要依赖于jdk,因此需要知道你电脑jdk装在哪一个位置,他会去找系统变量中的一个环境变量叫做JAVA_HOME。该变量指向jdk的根目录,指定tomcat启动时使用哪一个位置的jdk。
如何配置JAVA_HOME环境变量:
变量名: JAVA_HOME
变量值: C:\Program Files\Java\jdk1.8.0_45
--------------------------------------------------------------------------------
(扩展内容)配置Path变量的两种方式:
方式一:
Path=C:\Program Files\Java\jdk1.8.0_45\bin;xxx;xxx;xxx;
方式二:
JAVA_HOME=C:\Program Files\Java\jdk1.8.0_45
Path=%JAVA_HOME%\bin;xxx;xxx;xxx;
--------------------------------------------------------------------------------
启动、关闭tomcat服务器:
通过 [tomcat根目录]\bin\startup.bat 可以启动tomcat服务器;
通过 [tomcat根目录]\bin\shutdown.bat 可以关闭tomcat服务器;
访问测试服务器:
在tomcat服务器启动后,服务器会默认监听8080端口,可以通过如下地址访问tomcat服务器的主页:http://localhost:8080
修改tomcat默认端口

tomcat服务器在启动时,默认监听的端口是8080,这意味着,我们在访问tomcat服务器时,就需要在主机名(localhost)或者IP地址(127.0.0.1)等后面加上端口。这样非常不方便。
可以将8080端口改为80端口,因为80端口非常特殊,可以省略不写(只有80端口可以省略,其他端口可在访问时必须得加上)
修改方法:找到 [tomcat安装目录]\conf\server.xml 文件并打开该文件,将文件中的 69 行的

改完后,保存文件,重新启动服务器(只有在服务器启动时,才会重新加载server.xml文件)再次启动的服务器就会监听新的端口。

tomcat目录结构
tomcat目录结构介绍

tomcat服务器安装根目录下有很多子目录,这些目录的作用是:

虚拟主机和Web应用

总结;(1)虚拟主机就是tomcat服务器中配置的一个站点,在tomcat服务器中默认提供了一个localhost虚拟主机,这个主机的发布目录是webapps目录,这样意味着,将Web应用放在webapps目录下,就表示发不到了localhost虚拟主机中。
(2)Web应用就是一个存放了很多Web资源(html、css、js、jsp、servlet、图片等)的目录,将Web应用发布到虚拟主机中,就可以通过浏览器来访问Web资源中的资源文件了。
Web应用
web应用的目录结构

其中news就是一个目录, 同时也是一个web应用程序, 其中可以包含很多的资源文件。
部署web应用到虚拟主机中
直接将Web应用的目录拷贝到虚拟主机所管理的目录下,就发布到了虚拟主机中
例如:将news目录拷贝webapps目录下,由于webapps目录是localhost主机默认管理的目录,所以就相当于将news应用发布到 了localhost主机中。
通过如下路径规则就可以访问localhost主机下的news应用下的资源文件:http://localhost:端口/news/xxx
扩展内容(了解)
访问tomcat服务器主页:http://localhost
访问news/hello.html:http://localhost/news/hello.html
能否将访问 news/hello.html 的路径缩短一些(比如只通过主机名就可以访问news/hello.html这个网页)
配置WEB应用的主页
如果没有将 hello.html 配置为当前Web应用的主页,在访问 hello.html 时的路径为:http://localhost/news/hello.html
如果将 hello.html 配置为当前Web应用的主页,再次访问 hello.html 时的路径为:http://localhost/news
在上的路径中,/hello.html 这个路径可以加,也可以省略。
将 hello.html 配置为当前应用的主页,方式为:找到 [当前Web应用]/WEB-INF/web.xml文件并打开,在web.xml文件的根标签内部添加如下配置:

配置完后,需要重启服务器,配置才会生效。
配置缺省的(默认的)WEB应用
上面已经将news/hello.html配置为news应用的主页,访问hello.html时路径为:http://localhost/news/
如果不将 news 应用配置为默认的Web应用,在访问 news 下的 hello.html(主页)时的访问路径为:http://localhost/news/
如果将 news 应用配置为缺省的(默认的)Web应用,在访问 hello.html(主页)时的路径就变成了:http://localhost/
如何将 news 配置为缺省的(默认的)Web应用(缺省Web应用只能有一个)?:
将Web应用的名字改为一个大写的ROOT,当前Web应用就是一个默认的Web应用,再访问这个Web应用下的资源文件时,访问的路径中就可以不用写Web应用的名称了。
打war包
war包和jar包都是java程序中的一种压缩包格式,如果开发一个Java基础工程,可以将其中编译后的class文件和相关的配置文件打成一个jar包。
可以将一个Web应用打成一个war包,这样做的好处有:

打war包的方法是:
进入到web应用的目录下,将Web应用目录下的所有子目录和文件全部选中,右键压缩成一个 xxx.zip 包,再把 xxx.zip 改为 xxx.war即可!!
需要注意的是,如果有以下问题,可能会导致war不会自动解压:

将tomcat整合到Eclipse中
将Tomcat服务器整合到Eclipse工具中,可以通过Eclipse启动、关闭tomcat服务器,更重要的是,可以非常方便的将在Eclipse中创建的Web项目发布到Tomcat服务器中运行。
方式一:在window偏好设置中配置Tomcat
1、点击Window --> Preferences(偏好设置):

2、在偏好设置窗口中点击 Server --> Runtime Environments --> add:

3、在弹出的窗口中选择 --> Apache --> Apache Tomcat v8.5,需要注意的是,这里得根据自己安装的tomcat版本进行选择,比如我安装是8.5版本的tomcat,所以这里选择Apache Tomcat v8.5。

4、在下面的窗口中配置tomcat服务器的安装根目录,可以直接把路径复制到第二个输入框中;也可以点击后面的 Browse按钮在文件管理器中选择tomcat服务器安装根目录。

方式二:在创建Web项目时配置Tomcat
1、如果在创建Web项目时,Target runtime选项中没有配置可选的服务器,可以点击右面的选项进行配置
点击后进入下一步操作。

2、在弹出的窗口中选择 --> Apache --> Apache Tomcat v8.5,需要注意的是,这里得根据自己安装的tomcat版本进行选择,比如我安装是8.5版本的tomcat,所以这里选择Apache Tomcat v8.5。

3、在下面的窗口中配置tomcat服务器的安装根目录,可以直接把路径复制到第二个输入框中;也可以点击后面的 Browse按钮在文件管理器中选择tomcat服务器安装根目录。

4、上一步完成后,回到Web项目创建的视图窗口,再查看"Target runtime"选项,如下:

将整合到Eclipse中的tomcat从Eclipse中删除
如果要将整合到Eclipse中的tomcat从Eclipse删除:点击Windows --> Preferences --> Server --> Runtime Environments,选中要删除的服务器,点击右侧的删除按钮即可删除,最后点击Apply and Close保存设置即可!

在Eclipse中创建Server及移除Server
上面讲解了如何将Tomcat整合到Eclipse中,整合之后,需要在Eclipse中创建一个Server才可以进行启动tomcat、关闭tomcat等操作。
1、Eclipse中找到Servers窗口:

2、如果没有可以到Window --> Show View --> Other中搜索"servers",如下图:


3、在Server窗口中点击“No servers are available…”链接:

4、在弹出的窗口中,保持默认配置,直接点击完成
如果弹出的窗口中默认的服务器不是tomcat,则说明在此之前没有将Tomcat整合到Eclipse中。

5、在上一步点完成后,Eclipses左侧会多出一个Servers项目,Servers窗口中会出现创建的Server,也就是tomcat服务器。
注意:①处的Servers项目不能关闭(close),更不能删除(delete)

6、在创建完Server后,双击tomcat,可以修改Tomcat服务器配置
(1)将Server Locations中的选项切换为第二个选项
(2)将Deploy Path右侧的输入框中的内容改为webapps。ctrl+s保存配置即可

以上配置是为了保证在Eclipse中发布Web应用到tomcat服务器中时,可以将项目发布到tomcat服务器的webapps目录下。
如果不配置,会导致tomcat服务器中webapps下的Web应用无法访问。
7、如果要移除添加的Server,需要同时删除①处的Servers项目(右键delete,要彻底从硬盘上删除),以及删除②处的tomcat服务器(右键delete)
tomcat右键选项介绍

a) Start:用于启动tomcat服务器,如果已启动,则显示 ReStart,作用是重启服务器
b) Stop:用于停止服务器
c) Add and Remove:将Web应用部署到tomcat服务器中,或者移除服务器中部署的Web应用
d) Clean:作用是将发布到Eclipse自己的webapps目录中的项目删除再重新部署
e) Clean Tomcat Work Directory:作用是将在tomcat运行过程中存入work目录的文件删除
tomcat启动失败常见原因
问题1:tomcat服务器启动失败-1
如果在启动服务器时,服务器启动失败,并弹出窗口显示如下异常信息:

根据上面的描述信息,可以看出是8005、8080、8009端口被同时占用了,此时只有一种可能,就是之前已经启动了tomcat或者之前开启的tomcat没有完全关闭导致的。
解决方式:到tomcat安装目录找到bin目录中的shutdown.bat文件,双击运行将服务器关闭,再到Eclipse中启动服务器即可!
问题2:tomcat服务器启动失败-2
如果在启动服务器时,服务器启动失败,并弹出窗口显示如下异常信息:

解决方法:
(1) 可以先将服务器中所有的Web应用移除(在服务器上右键,Add and Remove-->Remove All-->Finish)
(2) 再分别执行服务器右键选项中的clean和Clean Tomcat Work Directory
(3)再次启动服务器,如果启动没有报错,则说明tomcat服务器本身没有问题,再将要运行的项目发布到tomcat中,再次启动服务器,观察是否有错误。如果有则说明是项目本身的问题。
(4)如果移除了所有的Web应用,启动tomcat服务器报错,则说明tomcat本身就有问题,可以将tomcat服务器重新配置一次到Eclipse中(将tomcat和Server项目删除,再点击链接重新创建Server)

浙公网安备 33010602011771号