Loading

HDU 5113 Black And White(dfs+剪枝)

Black And White

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 7177    Accepted Submission(s): 1933
Special Judge


Problem Description
In mathematics, the four color theorem, or the four color map theorem, states that, given any separation of a plane into contiguous regions, producing a figure called a map, no more than four colors are required to color the regions of the map so that no two adjacent regions have the same color.
— Wikipedia, the free encyclopedia

In this problem, you have to solve the 4-color problem. Hey, I’m just joking.

You are asked to solve a similar problem:

Color an N × M chessboard with K colors numbered from 1 to K such that no two adjacent cells have the same color (two cells are adjacent if they share an edge). The i-th color should be used in exactly ci cells.

Matt hopes you can tell him a possible coloring.
 
Input
The first line contains only one integer T (1 ≤ T ≤ 5000), which indicates the number of test cases.

For each test case, the first line contains three integers: N, M, K (0 < N, M ≤ 5, 0 < K ≤ N × M ).

The second line contains K integers ci (ci > 0), denoting the number of cells where the i-th color should be used.

It’s guaranteed that c1 + c2 + · · · + cK = N × M .
 
Output
For each test case, the first line contains “Case #x:”, where x is the case number (starting from 1).

In the second line, output “NO” if there is no coloring satisfying the requirements. Otherwise, output “YES” in one line. Each of the following N lines contains M numbers seperated by single whitespace, denoting the color of the cells.

If there are multiple solutions, output any of them.
 
Sample Input
4 1 5 2 4 1 3 3 4 1 2 2 4 2 3 3 2 2 2 3 2 3 2 2 2
 
Sample Output
Case #1: NO Case #2: YES 4 3 4 2 1 2 4 3 4 Case #3: YES 1 2 3 2 3 1 Case #4: YES 1 2 2 3 3 1
 

题目大意与分析

N*M块砖,分别涂成K种颜色,每种颜色可以涂c[i]块砖,问能否涂色使得相邻的砖块不一样

dfs,从左上角搜索到右下角,只需要判断是否和上面与左面的砖块颜色是否相同,不剪枝会TLE

剪枝:当剩下的砖块数量+1小于某种颜色的数量的两倍,则return,因为这时必然会相邻

#include<bits/stdc++.h>

using namespace std;

int flag,mp[10][10],n,m,k,c[50],Case,t;

int check(int x,int y,int color)
{
    if(x==1&&y==1)
    {
        return 1;
    }
    if(x==1)
    {
        if(mp[x][y-1]!=color)
        return 1;
        else
        return 0;
    }
    if(y==1)
    {
        if(mp[x-1][y]!=color)
        return 1;
        else
        return 0;
    }
    if(mp[x][y-1]!=color&&mp[x-1][y]!=color)
    {
        return 1;
    }
    else
    {
        return 0;
    }
}

void dfs(int x,int y,int sum)
{
    if(flag)
    return;
    for(int i=1;i<=k;i++)
    {
        if((sum+1)/2<c[i])
        return;
    }
    for(int i=1;i<=k;i++)
    {
        if(check(x,y,i)&&c[i]>0)
        {
            mp[x][y]=i;
            c[i]--;
            if(x==n&&y==m&&flag==0)
            {
                flag=1;
                cout<<"Case #"<<Case<<":"<<endl;
                cout<<"YES"<<endl;
                for(int ii=1;ii<=n;ii++)
                {
                    cout<<mp[ii][1];
                    for(int jj=2;jj<=m;jj++)
                    {
                        cout<<' '<<mp[ii][jj];
                    }
                    cout<<endl;
                }
            }
            else if(y==m)
            {
                dfs(x+1,1,sum-1);
            }
            else
            {
                dfs(x,y+1,sum-1);
            }
            mp[x][y]=0;
            c[i]++;
        }
    }
}

int main()
{
    cin>>t;
    while(t--)
    {
        flag=0;
        memset(mp,0,sizeof(mp));
        Case++;
        cin>>n>>m>>k;
        for(int i=1;i<=k;i++)
        {
            cin>>c[i];
        }
        dfs(1,1,n*m);
        if(flag==0)
        {
            cout<<"Case #"<<Case<<":"<<endl;
            cout<<"NO"<<endl;
        }
    }
    
}

 

posted @ 2020-04-09 10:35  dyhaohaoxuexi  阅读(180)  评论(0编辑  收藏  举报