458 - The Decoder

 The Decoder 

Write a complete program that will correctly decode a set of characters into a valid message. Your program should read a given file of a simple coded set of characters and print the exact message that the characters contain. The code key for this simple coding is a one for one character substitution based upon a single arithmetic manipulation of the printable portion of the ASCII character set.

 

Input and Output

For example: with the input file that contains:

 

1JKJ'pz'{ol'{yhklthyr'vm'{ol'Jvu{yvs'Kh{h'Jvywvyh{pvu5
1PIT'pz'h'{yhklthyr'vm'{ol'Pu{lyuh{pvuhs'I|zpulzz'Thjopul'Jvywvyh{pvu5
1KLJ'pz'{ol'{yhklthyr'vm'{ol'Kpnp{hs'Lx|pwtlu{'Jvywvyh{pvu5

your program should print the message:

*CDC is the trademark of the Control Data Corporation.
*IBM is a trademark of the International Business Machine Corporation.
*DEC is the trademark of the Digital Equipment Corporation.

Your program should accept all sets of characters that use the same encoding scheme and should print the actual message of each set of characters.

 

Sample Input

 

1JKJ'pz'{ol'{yhklthyr'vm'{ol'Jvu{yvs'Kh{h'Jvywvyh{pvu5
1PIT'pz'h'{yhklthyr'vm'{ol'Pu{lyuh{pvuhs'I|zpulzz'Thjopul'Jvywvyh{pvu5
1KLJ'pz'{ol'{yhklthyr'vm'{ol'Kpnp{hs'Lx|pwtlu{'Jvywvyh{pvu5

 

Sample Output

 

*CDC is the trademark of the Control Data Corporation.
*IBM is a trademark of the International Business Machine Corporation.
*DEC is the trademark of the Digital Equipment Corporation.



其实这道题不用读题亦可以很容易的知道是个字符替代问题,仔细一看,其实就是ASC2码向前走7位,自己写了个程序,但发现还有更简单的,遂copy之:

自己写的:

#include "stdio.h"
#include "string.h"

int main ()
{
char temp[1000];
while(gets(temp)!=NULL)
{
for(int i=0;i<strlen(temp);i++)
printf("%c",temp[i]-7);
printf("\n");
}
}

 

 

最简代码:

#include <cstdio>   

int main(void)  

{  

    char ch;  

    while (~(ch = getchar()))  

        putchar(ch == '\n' ? '\n' : ch - 7);  

    return 0;  

}  

posted @ 2014-01-15 13:34  dxywx  阅读(222)  评论(0编辑  收藏  举报