centos 7(Linux) 下yum安装mysql

1:查询centos7 中是否有可安装的mysql。命令查询

  yum list mysql*

没有可安装的mysql软件。。。

2:sudo rpm -Uvh http://dev.mysql.com/get/mysql-community-release-el7-5.noarch.rpm

在centos7中添加mysql的软件包。继续使用yum list mysql* ,如下图所示。。

3:安装mysql ,命令yum  -y install mysql-community-server.x86_64 。

4:安装完的mysql 是没有密码的。直接通过mysql -uroot 进入。出现Can‘t connect to local MySQL server through socket ‘/var/lib/mysql/mysql.sock‘ (2)错误。

登录时有可能报这样的错:ERROR 2002 (HY000): Can‘t connect to local MySQL server through socket ‘/var/lib/mysql/mysql.sock‘ (2),原因是/var/lib/mysql的访问权限问题。下面的命令把/var/lib/mysql的拥有者改为当前用户:

sudo chown -R root:root /var/lib/mysql

5:重启服务mysql  ->>service mysqld restart 或者 systemctl restart mysqld

6:修改密码

(1) use mysql 

(2) update user set password=password(‘123456‘) where user=‘root‘;

(3) 重启mysql服务。service mysqld restart 或者 systemctl restart mysqld后mysql 密码可以使用

7:开放远程登录权限

GRANT ALL PRIVILEGES ON *.* TO 'root'@'%' IDENTIFIED BY 'root' WITH GRANT OPTION;
FLUSH PRIVILEGES;

posted on 2017-09-20 15:41  多情小号  阅读(144)  评论(0)    收藏  举报

导航