poj 2524 Ubiquitous Religions

Problem Description
There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.
 

 

Input
The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.
 

 

Output
For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.
 

 

Sample Input
10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0
 

 

Sample Output
Case 1: 1
Case 2: 7
这题是并查集的基本应用
#include<stdio.h>
int father[50001],rank[50001];//father[x]记录x的父节点,rank[x]记录每个集合中元素的数量
int find(int x)
{
    if(x!=father[x])
        father[x]=find(father[x]);//回溯时路径压缩
    return father[x];
}
void uion(int x,int y)//合并x和y所在的集合
{
    x=find(x);
    y=find(y);
    if(x==y) return ;
    if(rank[x]>rank[y])
    {
        father[y]=x;
        rank[x]+=rank[y];
    }
    else if(rank[x]<rank[y])
    {
        father[x]=y;
        rank[y]+=rank[x];
    }
    else {
        rank[x]*=2;
        father[y]=x;
    }
}
int main()
{
    int n,m,i,j=1,a,b,count;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n==0&&m==0) break;
        for(i=1;i<=n;i++)
        {
            father[i]=i;
            rank[i]=1;
        }
        for(i=1;i<=m;i++)
        {
            scanf("%d%d",&a,&b);
            uion(a,b);
        }
        count=0;
        for(i=1;i<=n;i++)
            if(find(i)==i)
                count++;
        printf("Case %d: %d\n",j,count);
        j++;
    }
    return 0;
}

 

posted @ 2014-01-08 17:15  段少  阅读(173)  评论(0编辑  收藏  举报