Olympiad

  

Olympiad

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 10    Accepted Submission(s): 8
Problem Description

You are one of the competitors of the Olympiad in numbers. The problem of this year relates to beatiful numbers. One integer is called beautiful if and only if all of its digitals are different (i.e. 12345 is beautiful, 11 is not beautiful and 100 is not beautiful). Every time you are asked to count how many beautiful numbers there are in the interval [a,b] (a≤b). Please be fast to get the gold medal!


 
Input

The first line of the input is a single integer T (T≤1000), indicating the number of testcases.
For each test case, there are two numbers a and b, as described in the statement. It is guaranteed that 1≤a≤b≤100000.


 
Output

For each testcase, print one line indicating the answer.


 
Sample Input

2 1 10 1 1000


 
Sample Output

10 738

#include<iostream>
#include<cstdio>
#include<algorithm>

using namespace std;

bool num[100010];

int fun(int x)
{
    int vis[50]={0};
    while(x)
    {
        int a=x%10;
        if(vis[a]==1)
            return 0;
        vis[a]=1;
        x/=10;
    }
    return 1;
}

int main()
{
    for(int i=1;i<=100000;i++)
    {
        if(fun(i))
            num[i]=1;
        else
            num[i]=0;
    }

    int t,a,b;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&a,&b);
        int s=0;
        for(int i=a;i<=b;i++)
            if(num[i]==1)
            s++;
        printf("%d\n",s);
    }
    return 0;
}

 



posted @ 2015-08-22 16:46  Lincy*_*  阅读(246)  评论(0编辑  收藏  举报