1140 Look-and-say Sequence (20 分)

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, ...
 

where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1's, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:

1 8
 

Sample Output:

1123123111
 
题解:遍历字符串,每遇到一个字符就下,并循环比较后一位是否与之相同,设立计数器计数
#include<bits/stdc++.h>
using namespace std;
int main(){
    string s;
    int n;
    cin>>s>>n;
    for(int i=0;i<n-1;i++){
        string ss="";
        int cnt=0;
        for(int j=0;j<s.length();j++){
            ss+=s[j];
            cnt=0;
            while(s[j+1]==s[j]){
                cnt++;
                j++;
            }
            if(cnt>0){
                cnt++;
                ss+=(cnt+'0');
            }
            else{
                ss+='1';
            }
        }
        s=ss;
    }
    cout<<s<<endl;
    return 0;
}

 

posted @ 2021-07-10 22:34  XA科研  阅读(36)  评论(0编辑  收藏  举报