1067 Sort with Swap(0, i) (25 分)

Given any permutation of the numbers {0, 1, 2,..., N1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}
 

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (≤) followed by a permutation sequence of {0, 1, ..., N1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1
 

Sample Output:

9


#include<bits/stdc++.h>
using namespace std;
const int maxn=100010;
int pos[maxn];
int main(){
    int n,ans=0;
    scanf("%d",&n);
    int temp,count=n-1;
    for(int i=0;i<n;i++){
        scanf("%d",&temp);
        pos[temp]=i;
        if(temp==i&&temp!=0){
            count--;
        }
    }
    int k=1;//存放除0之外的最小需要交换的值
    while(count>0){
        if(pos[0]==0){
            while(k<n){
                if(pos[k]!=k){
                    swap(pos[k],pos[0]);
                    ans++;
                    break;
                }
                k++;
            }
        }
        while(pos[0]!=0){
            swap(pos[0],pos[pos[0]]);//将0所在位置上的数的位置与0的位置交换
            ans++;
            count--;
        }
    }
    printf("%d\n",ans);

    return 0;
}

 

posted @ 2021-03-05 22:42  XA科研  阅读(56)  评论(0编辑  收藏  举报