1046 Shortest Distance (20 分)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3]), followed by N integer distances D1​​ D2​​ ⋯ DN​​, where Di​​ is the distance between the i-th and the (-st exits, and DN​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 1.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1
 

Sample Output:

3
10
7
 
 此题非常卡时间
 
#include<bits/stdc++.h>
using namespace std;
const int maxn=100010;
int dis[maxn];
int main(){
    int n,m;
    scanf("%d",&n);
    dis[0]=0;
    for(int i=1;i<=n;i++){
        scanf("%d",&dis[i]);
        if(i>=2){
            dis[i]=dis[i]+dis[i-1];
        }
    }
    int a,b;
    scanf("%d",&m);
    for(int i=0;i<m;i++){
        scanf("%d %d",&a,&b);
        int temp;
        if(a>b){
            temp=a;
            a=b;
            b=temp;
        }
        int sum1=0,sum2=0;
        sum1+=dis[b-1]-dis[a-1];
        sum2+=dis[n]-dis[b-1]+(dis[a-1]-dis[0]);
        if(sum1>sum2){
            printf("%d\n",sum2);
        }
        else{
            printf("%d\n",sum1);
        }
    }
    return 0;
}

 优化:

#include<bits/stdc++.h>
using namespace std;
const int maxn=100010;
int dis[maxn];
int main(){
    int n,m,temp,sum=0;
    scanf("%d",&n);
    dis[0]=0;
    for(int i=1;i<=n;i++){
        scanf("%d",&temp);
        sum+=temp;
        dis[i]=sum;
    }
    int a,b;
    scanf("%d",&m);
    for(int i=0;i<m;i++){
        scanf("%d %d",&a,&b);
        if(a>b){
            swap(a,b);
        }
        int sum1=0,sum2=0;
        sum1=dis[b-1]-dis[a-1];
        sum2=sum-sum1;
        if(sum1>sum2){
            printf("%d\n",sum2);
        }
        else{
            printf("%d\n",sum1);
        }
    }
    return 0;
}

 

posted @ 2021-03-01 20:17  XA科研  阅读(45)  评论(0编辑  收藏  举报