1019 General Palindromic Number (20分)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b2, where it is written in standard notation with k+1 digits ai​​ as (. Here, as usual, 0 for all i and ak​​ is non-zero. Then N is palindromic if and only if ai​​=aki​​ for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0 is the decimal number and 2 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "ak​​ ak1​​ ... a0​​". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2
 

Sample Output 1:

Yes
1 1 0 1 1
 

Sample Input 2:

121 5
 

Sample Output 2:

No
4 4 1

题解:
判断b进制下的N是否为回文数

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<vector>
#include<cmath>
#include<cstring>
#include<queue>
#include<string.h>
using namespace std;
typedef long long ll;
const int maxn=1010;
vector<int> v;
bool isP(int N,int b){
    int m,k;
    m=N;
    while(m>0){
        k=m%b;
        v.push_back(k);
        m/=b;
    }
    for(int i=0;i<=v.size()/2;i++){
        if(v[i]!=v[v.size()-i-1]){
            return false;
        }
    }
    return true;
}

int main(){
    int N,b;
    scanf("%d %d",&N,&b);
    if(isP(N,b)){
        printf("Yes\n");
    }else{
        printf("No\n");
    }
    for(int i=v.size()-1;i>=0;i--){
        if(i>0){
            printf("%d ",v[i]);
        }
        else{
            printf("%d\n",v[i]);
        }
    }
    return 0;
} 

 

 
posted @ 2021-01-24 21:40  XA科研  阅读(79)  评论(0编辑  收藏  举报