HDU 1297 Children’s Queue【大数加法 + 递推】

Problem Description
There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like
FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM
Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?
Input
There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)
Output
For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.
Sample Input
1 2 3
Sample Output
1 2 4
分析: 找到递推式                                  // dp[n]=dp[n-1]*2-dp[n-2]+dp[n-3]
          但为了便于大数加法 把递推式改为    // dp[n]=dp[n-1]+dp[n-2]+dp[n-4]
code:
View Code
// dp[n]=dp[n-1]<<1-dp[n-2]+dp[n-3]
// dp[n]=dp[n-1]+dp[n-2]+dp[n-4]
#include<stdio.h>
#include<string.h>
int dp[1001][302];
void pl(int s1[],int s2[],int s3[],int s4[])
{
int i,c;
for(i=0;i<=300;i++)
s4[i]+=s1[i]+s2[i]+s3[i];
for(i=c=0;i<=300;i++)
{
s4[i]+=c;
c=s4[i]/10;
s4[i]=s4[i]%10;
}
}

int main()
{
int i,j,n;
memset(dp,0,sizeof(dp));
dp[1][0]=1; dp[2][0]=2; dp[3][0]=4; dp[4][0]=7;
for(i=5;i<=1000;i++)
pl(dp[i-1],dp[i-2],dp[i-4],dp[i]);
while(scanf("%d",&n)!=EOF)
{
for(i=300;i>=0;i--)
if(dp[n][i])
break;
for(j=i;j>=0;j--)
printf("%d",dp[n][j]);
printf("\n");
}
return 0;
}
posted @ 2012-04-05 20:41  'wind  阅读(244)  评论(0编辑  收藏  举报