DHU 4004 The Frog's Games【二分】

Problem Description
The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).
Input
The input contains several cases. The first line of each case contains three positive integer L, n, and m.
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.
Output
For each case, output a integer standing for the frog's ability at least they should have.
Sample Input
6 1 2 2 25 3 3 11 2 18
Sample Output
4 11
分析: 二分枚举长度,求出满足要求的最小长度。
View Code
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int cmp(const void*p1,const void*p2)
{ return *(int*)p1-*(int*)p2; }
int dis[500004];
int n,m,l;
int ok(int x)
{
int i,tot=0,low=0;
for(i=1;i<=n+1;i++)
{
if(dis[i]-low>x)
{
low=dis[i-1];
tot++;
}
}
if(tot+1<=m)
return 1;
return 0;
}
int main()
{
int low,high,mid,i;
while(scanf("%d%d%d",&l,&n,&m)!=EOF)
{
dis[0]=0;
for(i=1;i<=n;i++)
scanf("%d",&dis[i]);
qsort(dis+1,n,sizeof(int),cmp);
low=l-dis[n];
for(i=1;i<=n;i++)
if(low<dis[i]-dis[i-1])
low=dis[i]-dis[i-1];
dis[n+1]=l;
high=l;
while(low<high)
{
mid=(low+high)>>1;
if(ok(mid))
high=mid;
else low=mid+1;
}
printf("%d\n",high);
}
return 0;
}
posted @ 2012-04-05 00:27  'wind  阅读(228)  评论(0编辑  收藏  举报